UbuntuUpdates.org

Package "gst-plugins-good1.0"

Name: gst-plugins-good1.0

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GStreamer plugins from the "good" set
  • GStreamer plugin for Qt5

Latest version: 1.16.3-0ubuntu1.1
Release: focal (20.04)
Level: updates
Repository: universe

Links



Other versions of "gst-plugins-good1.0" in Focal

Repository Area Version
base main 1.16.2-1ubuntu2
base universe 1.16.2-1ubuntu2
security main 1.16.3-0ubuntu1.1
security universe 1.16.3-0ubuntu1.1
updates main 1.16.3-0ubuntu1.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.16.3-0ubuntu1.1 2022-08-08 18:06:29 UTC

  gst-plugins-good1.0 (1.16.3-0ubuntu1.1) focal-security; urgency=medium

  * SECURITY UPDATE: Integer overflow
    - debian/patches/CVE-2022-1920.patch: avoid integer overflow
      resulting in heap corruption in WavPack header handling code
      in gst/matroska/matroska-demux.c.
    - CVE-2022-1920
  * SECURITY UPDATE: Integer overflow
    - debian/patches/CVE-2022-1921.patch: fix integer overflow resulting
      in heap corruption in DIB buffer inversion code in
      gst/avi/gstavidemux.c.
    - CVE-2022-1921
  * SECURITY UPDATE: Integer overflows
    - debian/patches/CVE-2022-1922-1923-1924-1925-and-2122.patch: fix
      integer overflows in zblib/bz2/etc decompression code in
      gst/matroska/matroska-read-commnon.c.
    - debian/patches/fix_integer_overflows_in_zlib.patch: fix in
      gst/isomp4/qtdemux.c.
    - CVE-2022-1922
    - CVE-2022-1923
    - CVE-2022-1924
    - CVE-2022-1925
    - CVE-2022-2122

 -- Leonidas Da Silva Barbosa <email address hidden> Tue, 26 Jul 2022 07:23:44 -0300

Source diff to previous version
CVE-2022-1920 Integer overflow in matroskademux element in gst_matroska_demux_add_wvpk_header function which allows a heap overwrite while parsing matroska files.
CVE-2022-1921 Integer overflow in avidemux element in gst_avi_demux_invert function which allows a heap overwrite while parsing avi files. Potential for arbitrary
CVE-2022-1922 DOS / potential heap overwrite in mkv demuxing using zlib decompression. Integer overflow in matroskademux element in gst_matroska_decompress_data fu
CVE-2022-1923 DOS / potential heap overwrite in mkv demuxing using bzip decompression. Integer overflow in matroskademux element in bzip decompression function whi
CVE-2022-1924 DOS / potential heap overwrite in mkv demuxing using lzo decompression. Integer overflow in matroskademux element in lzo decompression function which
CVE-2022-1925 DOS / potential heap overwrite in mkv demuxing using HEADERSTRIP decompression. Integer overflow in matroskaparse element in gst_matroska_decompress_
CVE-2022-2122 DOS / potential heap overwrite in qtdemux using zlib decompression. Integer overflow in qtdemux element in qtdemux_inflate function which causes a se

Version: 1.16.3-0ubuntu1 2022-08-03 04:07:16 UTC

  gst-plugins-good1.0 (1.16.3-0ubuntu1) focal; urgency=medium

  * New upstream stable release (LP: #1962135)

 -- Jeremy Bicha <email address hidden> Tue, 01 Mar 2022 11:48:14 +0100

Source diff to previous version
1962135 [SRU] gstreamer 1.16.3 series

Version: 1.16.2-1ubuntu2.1 2021-04-28 19:06:37 UTC

  gst-plugins-good1.0 (1.16.2-1ubuntu2.1) focal-security; urgency=medium

  * SECURITY UPDATE: Use after free
    - debian/patches/CVE-2021-3497.patch: Fix extraction of multichannel WavPack
      in gst/matroska/matroska-demux.c, gst/matroska/matroska-ids.h.
    - CVE-2021-3497
  * SECURITY UPDATE: Heap corruption
    - debian/patches/CVE-2021-3498.patch: Initialize track context out parameter to NULL
      before parsing in gst/matroska/matroska-demux.c.
    - CVE-2021-3498

 -- Leonidas Da Silva Barbosa <email address hidden> Thu, 15 Apr 2021 11:49:56 -0300

CVE-2021-3497 GStreamer before 1.18.4 might access already-freed memory in error code paths when demuxing certain malformed Matroska files.
CVE-2021-3498 GStreamer before 1.18.4 might cause heap corruption when parsing certain malformed Matroska files.



About   -   Send Feedback to @ubuntu_updates