UbuntuUpdates.org

Package "libcephfs-jni"

Name: libcephfs-jni

Description:

Java Native Interface library for CephFS Java bindings

Latest version: 15.2.3-0ubuntu0.20.04.1
Release: focal (20.04)
Level: proposed
Repository: universe
Head package: ceph
Homepage: http://ceph.com/

Links


Download "libcephfs-jni"


Other versions of "libcephfs-jni" in Focal

Repository Area Version
base universe 15.2.1-0ubuntu1
updates universe 15.2.1-0ubuntu2

Changelog

Version: 15.2.3-0ubuntu0.20.04.1 2020-06-23 23:07:21 UTC

  ceph (15.2.3-0ubuntu0.20.04.1) focal; urgency=medium

  * New upstream point release (LP: #1880084).
  * d/p/32bit-fixes.patch: Misc fixes for 32 bit architecture build
    failures.
  * d/p/riscv64-link-pthread.patch: Refresh.
  * d/p/revert-rgw-move-frontends-initial-init-to-after-glob.patch:
    Drop, equivalent fix included in upstream release.

 -- James Page <email address hidden> Wed, 17 Jun 2020 06:01:56 +0100

1880084 [SRU] ceph 15.2.3

Version: *DELETED* 2020-05-04 09:06:37 UTC
No changelog for deleted or moved packages.

Version: 15.2.1-0ubuntu2 2020-04-21 17:06:26 UTC

  ceph (15.2.1-0ubuntu2) focal; urgency=medium

  * Link with -pthread to fix FTBFS on riscv64.

 -- William Grant <email address hidden> Sun, 19 Apr 2020 13:58:15 +1000


Version: *DELETED* 2020-04-18 12:06:23 UTC
No changelog for deleted or moved packages.

Version: 15.2.1-0ubuntu1 2020-04-18 07:06:29 UTC

  ceph (15.2.1-0ubuntu1) focal; urgency=high

  * New upstream point release for Octopus (LP: #1873193):
    - CVE-2020-1759: Fixed nonce reuse in msgr V2 secure mode.
    - CVE-2020-1760: Fixed XSS due to RGW GetObject header-splitting.
  * d/copyright: Restore excluded files.

 -- James Page <email address hidden> Fri, 17 Apr 2020 20:08:37 +0100

1873193 ceph 15.2.1
CVE-2020-1759 A vulnerability was found in Red Hat Ceph Storage 4 and Red Hat Openshift Container Storage 4.2 where, A nonce reuse vulnerability was discovered in
CVE-2020-1760 header-splitting in RGW GetObject has a possible XSS



About   -   Send Feedback to @ubuntu_updates