UbuntuUpdates.org

Package "update-manager"

Name: update-manager

Description:

GNOME application that manages apt updates

Latest version: 1:20.04.10.9
Release: focal (20.04)
Level: updates
Repository: main

Links


Download "update-manager"


Other versions of "update-manager" in Focal

Repository Area Version
base main 1:20.04.9

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:20.04.10.9 2021-09-28 00:06:23 UTC

  update-manager (1:20.04.10.9) focal; urgency=medium

  * ubuntu-security-status: use ubuntu-advantage-tools to determine whether or
    not livepatch or esm are enabled and if the system is attached. Thanks to
    Chad Smith for the patch. (LP: #1938043)

 -- Brian Murray <email address hidden> Fri, 03 Sep 2021 15:17:22 -0700

Source diff to previous version
1938043 ubuntu-security-status

Version: 1:20.04.10.7 2021-05-06 10:06:26 UTC

  update-manager (1:20.04.10.7) focal; urgency=medium

  * tests/test_update_list.py: rewrite how APT::VersionedKernelPackages is set.
    (LP: #1924809)
  * debian/tests/control: add apt to the list of Depends.

 -- Brian Murray <email address hidden> Fri, 16 Apr 2021 16:25:21 -0700

Source diff to previous version
1924809 apt 2.0.5 in focal causes autopkgtest failures for update-manager

Version: 1:20.04.10.6 2021-03-04 13:06:58 UTC

  update-manager (1:20.04.10.6) focal; urgency=medium

  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)
  * Clean up apt cache binary files left behind by tests
  * Rename meta_pkgs to ubuntu_base_pkgs to make it more clear to the
    reader which packages should be included
  * Add tests in to ensure Ubuntu base packages are not grouped when
    staged for removal (LP: #1912718)

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 10 Feb 2021 14:39:27 -0600

Source diff to previous version
1902025 hwe kernel not scoped under \
1912718 update-manager: clicks do not toggle checkboxes for \

Version: 1:20.04.10.5 2021-01-29 22:07:05 UTC

  update-manager (1:20.04.10.5) focal; urgency=medium

  * UpdateManager/backend/__init__.py: Really make commit_oem a no-op in the
    base class to avoid crash when people force synaptic backend (LP: #1913732)
  * Fix typo in previous changelog

Source diff to previous version
1913732 /usr/bin/update-manager:NotImplementedError:\u003clambda\u003e:on_button_install_clicked:start_install:_start_pane:start:commit_oem

Version: 1:20.04.10.3 2021-01-21 18:06:18 UTC

  update-manager (1:20.04.10.3) focal; urgency=medium

  [ Julian Andres Klode ]
  * UpdateManager/backend/__init__.py: Fix unbound local variables regression
    introduced by the previous SRU (See LP 1910556), and correct comment

  [ William Wilson ]
  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)

1902025 hwe kernel not scoped under \



About   -   Send Feedback to @ubuntu_updates