UbuntuUpdates.org

Package "ubuntu-release-upgrader"

Name: ubuntu-release-upgrader

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • manage release upgrades
  • manage release upgrades
  • manage release upgrades

Latest version: 1:20.04.25
Release: focal (20.04)
Level: updates
Repository: main

Links



Other versions of "ubuntu-release-upgrader" in Focal

Repository Area Version
base universe 1:20.04.18
base main 1:20.04.18
updates universe 1:20.04.25
proposed universe 1:20.04.27
proposed main 1:20.04.27

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:20.04.25 2020-09-03 15:07:06 UTC

  ubuntu-release-upgrader (1:20.04.25) focal; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: Add a check for ROS packages being
    installed and warn that upgrades with them installed are not likely to
    work. Thanks to Kyle Fazzari for the patch. (LP: #1611737)
  * DistUpgrade/DistUpgradeController.py: do what the comment says and really
    back up /etc/apt/sources.list first. (LP: #1888916)

 -- Brian Murray <email address hidden> Wed, 26 Aug 2020 08:36:39 -0700

Source diff to previous version
1611737 Can't upgrade from a release if ros packages are installed from ROS servers
1888916 release upgrader can restore sources.list file from a previous release upgrade

Version: 1:20.04.24 2020-08-12 07:07:01 UTC

  ubuntu-release-upgrader (1:20.04.24) focal; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: Ensure that the linux metapackage is
    never removed during a distribution upgrade. (LP: #1889449)

 -- Brian Murray <email address hidden> Mon, 03 Aug 2020 09:26:16 -0700

Source diff to previous version
1889449 18.04 to 20.04.1 upgrade on raspberry pi removes too many kernel meta packages

Version: 1:20.04.23 2020-07-23 19:06:25 UTC

  ubuntu-release-upgrader (1:20.04.23) focal; urgency=medium

  * data/DistUpgrade.cfg: remove xscreensaver from the PostUpgradeRemove rule
    for ubuntu-desktop as it is no longer necessary. (LP: #1875107)

Source diff to previous version
1875107 unable to upgrade with lubuntu-desktop and ubuntu-desktop installed due to xscreensaver

Version: 1:20.04.21 2020-07-16 10:06:41 UTC

  ubuntu-release-upgrader (1:20.04.21) focal; urgency=medium

  * debian/91-release-upgrade: make it work in dash. (LP: #1873545)

Source diff to previous version
1873545 Permission denied error from show-motd when updates available

Version: 1:20.04.19 2020-05-07 16:08:32 UTC

  ubuntu-release-upgrader (1:20.04.19) focal; urgency=medium

  [ Dimitri John Ledkov ]
  * DistUpgradeCache: Ignore BaseMetaPkgs' & obsolete tasks during server upgrade
    (LP: #1872902)

  [ Brian Murray ]
  * data/mirrors.cfg: update as some mirrors have been removed as they do not
    mirror Ubuntu 20.04 LTS.
  * data/demoted.bionic.cfg: updated for packages that were removed nearer
    the release date.

 -- Brian Murray <email address hidden> Tue, 05 May 2020 15:26:02 -0700




About   -   Send Feedback to @ubuntu_updates