UbuntuUpdates.org

Package "strongswan"

Name: strongswan

Description:

IPsec VPN solution metapackage

Latest version: 5.8.2-1ubuntu3.4
Release: focal (20.04)
Level: updates
Repository: main
Homepage: http://www.strongswan.org

Links


Download "strongswan"


Other versions of "strongswan" in Focal

Repository Area Version
base universe 5.8.2-1ubuntu3
base main 5.8.2-1ubuntu3
security universe 5.8.2-1ubuntu3.4
security main 5.8.2-1ubuntu3.4
updates universe 5.8.2-1ubuntu3.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 5.8.2-1ubuntu3.4 2022-01-24 20:06:59 UTC

  strongswan (5.8.2-1ubuntu3.4) focal-security; urgency=medium

  * SECURITY UPDATE: Incorrect Handling of Early EAP-Success Messages
    - debian/patches/CVE-2021-45079.patch: enforce failure if MSK
      generation fails in src/libcharon/plugins/eap_gtc/eap_gtc.c,
      src/libcharon/plugins/eap_md5/eap_md5.c,
      src/libcharon/plugins/eap_radius/eap_radius.c,
      src/libcharon/sa/eap/eap_method.h,
      src/libcharon/sa/ikev2/authenticators/eap_authenticator.c.
    - CVE-2021-45079

 -- Marc Deslauriers <email address hidden> Tue, 11 Jan 2022 07:10:45 -0500

Source diff to previous version

Version: 5.8.2-1ubuntu3.3 2021-10-19 12:06:22 UTC

  strongswan (5.8.2-1ubuntu3.3) focal-security; urgency=medium

  * SECURITY UPDATE: Integer Overflow in gmp Plugin
    - debian/patches/CVE-2021-41990.patch: reject RSASSA-PSS params with
      negative salt length in
      src/libstrongswan/credentials/keys/signature_params.c,
      src/libstrongswan/plugins/gmp/gmp_rsa_public_key.c.
    - CVE-2021-41990
  * SECURITY UPDATE: Integer Overflow When Replacing Certificates in Cache
    - debian/patches/CVE-2021-41991.patch: prevent crash due to integer
      overflow/sign change in
      src/libstrongswan/credentials/sets/cert_cache.c.
    - CVE-2021-41991

 -- Marc Deslauriers <email address hidden> Tue, 12 Oct 2021 13:22:57 -0400

Source diff to previous version
CVE-2021-41990 The gmp plugin in strongSwan before 5.9.4 has a remote integer overflo ...
CVE-2021-41991 The in-memory certificate cache in strongSwan before 5.9.4 has a remot ...

Version: 5.8.2-1ubuntu3.2 2021-10-07 02:06:25 UTC

  strongswan (5.8.2-1ubuntu3.2) focal; urgency=medium

  * Compile the tpm plugin against the tpm2 software stack (tss2)
    (Debian packaging cherry-pick, LP: #1940079)
    - d/rules: add the --enable-tss-tss2 configure flag
    - d/control: add Build-Depends: libtss2-dev

 -- Paride Legovini <email address hidden> Fri, 17 Sep 2021 10:48:56 +0200

Source diff to previous version
1940079 Strongswan doesn't support TPM 2.0 through the TSS2 interface

Version: 5.8.2-1ubuntu3.1 2020-06-04 09:06:30 UTC

  strongswan (5.8.2-1ubuntu3.1) focal; urgency=medium

  * Re-enable eap-{dynamic,peap} libcharon plugins (LP: #1878887)
    - d/control: update libcharon-extra-plugins description.
    - d/libcharon-extra-plugins.install: install .so and conf files.
    - d/rules: add plugins to the configuration arguments.
  * Remove conf files of plugins removed from libcharon-extra-plugins
    - The conf file of the following plugins were removed: eap-aka-3gpp2,
      eap-sim-file, eap-sim-pcsc, eap-sim, eap-simaka-pseudonym,
      eap-simaka-reauth, eap-simaka-sql, xauth-noauth.
    - Created d/libcharon-extra-plugins.maintscript to handle the removals
      properly.
  * Add patches to fix the chunk_from_chars() macro compiled with GCC 9+
    (LP: #1879692)
    - Patches backported from upstream: lp-1879692-{1,2,3,4,5}.patch.
    - Fix the pki CA certificate creation issue.

 -- Lucas Kanashiro <email address hidden> Fri, 22 May 2020 10:53:07 -0300

1878887 [SRU] No EAP-PEAP support anymore
1879692 [SRU] Strongswan pki creates CA certificates with invalid Key Usage flags



About   -   Send Feedback to @ubuntu_updates