UbuntuUpdates.org

Package "libproxy"

Name: libproxy

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • automatic proxy configuration management library (devel)
  • automatic proxy configuration management library (GSettings plugin)
  • automatic proxy configuration management library (Network Manager plugin)
  • automatic proxy configuration management library (shared)

Latest version: 0.4.15-10ubuntu1.1
Release: focal (20.04)
Level: updates
Repository: main

Links



Other versions of "libproxy" in Focal

Repository Area Version
base main 0.4.15-10
base universe 0.4.15-10
security main 0.4.15-10ubuntu1.1
security universe 0.4.15-10ubuntu1.1
updates universe 0.4.15-10ubuntu1.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.4.15-10ubuntu1.1 2020-09-17 18:06:20 UTC

  libproxy (0.4.15-10ubuntu1.1) focal-security; urgency=medium

  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2020-25219.patch: rewrite url::recvline
      to be nonrecursive in libproxy/url.cpp.
    - CVE-2020-25219

 -- <email address hidden> (Leonidas S. Barbosa) Tue, 15 Sep 2020 12:45:29 -0300

Source diff to previous version
CVE-2020-25219 url::recvline in url.cpp in libproxy 0.4.x through 0.4.15 allows a remote HTTP server to trigger uncontrolled recursion via a response composed of an

Version: 0.4.15-10ubuntu1 2020-06-09 19:06:48 UTC

  libproxy (0.4.15-10ubuntu1) focal; urgency=medium

  * debian/patches/git_gsettings_warning.patch:
    - Backport a commit from upstream to fix warnings in GNOME environments
      (lp: #1875558)

 -- Sebastien Bacher <email address hidden> Wed, 20 May 2020 13:27:09 +0200

1875558 [SRU] libproxy1-plugin-gsettings triggers a lot of warnings



About   -   Send Feedback to @ubuntu_updates