UbuntuUpdates.org

Package "dnsmasq"

Name: dnsmasq

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Small caching DNS proxy and DHCP/TFTP server
  • Utilities for manipulating DHCP leases

Latest version: 2.80-1.1ubuntu1.6
Release: focal (20.04)
Level: updates
Repository: main

Links



Other versions of "dnsmasq" in Focal

Repository Area Version
base universe 2.80-1.1ubuntu1
base main 2.80-1.1ubuntu1
security main 2.80-1.1ubuntu1.5
security universe 2.80-1.1ubuntu1.5
updates universe 2.80-1.1ubuntu1.6

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.80-1.1ubuntu1.6 2022-12-05 12:06:27 UTC

  dnsmasq (2.80-1.1ubuntu1.6) focal; urgency=medium

  * src/cache.c: Apply 162e5e0062ce923c494cc64282f293f0ed64fc10 from
    upstream GIT to fix bug in DNS non-terminal code, added in 2.80,
    which could sometimes cause a NODATA rather than an NXDOMAIN
    reply (LP: #1995260).

 -- Miriam España Acebal <email address hidden> Tue, 15 Nov 2022 10:35:15 +0100

Source diff to previous version
1995260 dnsmasq focal 2.80 NODATA instead of NXDOMAIN bug

Version: 2.80-1.1ubuntu1.5 2022-05-10 20:06:20 UTC

  dnsmasq (2.80-1.1ubuntu1.5) focal-security; urgency=medium

  * SECURITY UPDATE: Heap use after free
    - debian/patches/CVE-2022-0934.patch: Fix write-after-free error in
      DHCPv6 code in src/rfc3315.c.
    - CVE-2022-0934

 -- Leonidas Da Silva Barbosa <email address hidden> Mon, 18 Apr 2022 12:25:39 -0300

Source diff to previous version

Version: 2.80-1.1ubuntu1.4 2021-06-02 15:06:24 UTC

  dnsmasq (2.80-1.1ubuntu1.4) focal-security; urgency=medium

  * SECURITY UPDATE: fixed port use when specific server is requested
    - 74d4fcd756a85bc1823232ea74334f7ccfb9d5d2
    - CVE-2021-3448

 -- Marc Deslauriers <email address hidden> Thu, 06 May 2021 12:34:24 -0400

Source diff to previous version
CVE-2021-3448 A flaw was found in dnsmasq in versions before 2.85. When configured to use a specific server for a given network interface, dnsmasq uses a fixed por

Version: 2.80-1.1ubuntu1.3 2021-02-24 16:07:52 UTC

  dnsmasq (2.80-1.1ubuntu1.3) focal-security; urgency=medium

  * SECURITY REGRESSION: issue with multiple queries and issue with retries
    (LP: #1916462)
    - backport multiple upstream commits to fix regressions
      + 04490bf622ac84891aad6f2dd2edf83725decdee
      + 12af2b171de0d678d98583e2190789e544440e02
      + 3f535da79e7a42104543ef5c7b5fa2bed819a78b
      + 25e63f1e56f5acdcf91893a1b92ad1e0f2f552d8
      + 141a26f979b4bc959d8e866a295e24f8cf456920
      + 305cb79c5754d5554729b18a2c06fe7ce699687a

 -- Marc Deslauriers <email address hidden> Tue, 23 Feb 2021 07:58:11 -0500

Source diff to previous version
1916462 dnsmasq failed to send packet: Network is unreachable

Version: 2.80-1.1ubuntu1.2 2021-01-19 15:07:14 UTC

  dnsmasq (2.80-1.1ubuntu1.2) focal-security; urgency=medium

  * SECURITY UPDATE: Multiple security issues
    - CVE-2020-25681: heap overflow in RRSets sorting
    - CVE-2020-25682: buffer overflow in extracting names from DNS packets
    - CVE-2020-25683: heap overflow in DNSSEC validation
    - CVE-2020-25684: cache poisoning issue via address/port
    - CVE-2020-25685: cache poisoning issue via weak hash
    - CVE-2020-25686: birthday attack via incorrect existing requests check
    - CVE-2020-25687: heap overflow in DNSSEC validation
    - CVE-2019-14834: memory leak via DHCP response creation

 -- Marc Deslauriers <email address hidden> Fri, 08 Jan 2021 09:59:59 -0500

CVE-2020-25681 RESERVED
CVE-2020-25682 RESERVED
CVE-2020-25683 RESERVED
CVE-2020-25684 RESERVED
CVE-2020-25685 RESERVED
CVE-2020-25686 RESERVED
CVE-2020-25687 RESERVED
CVE-2019-14834 A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote attackers to cause a denial of service (memory consumpt



About   -   Send Feedback to @ubuntu_updates