UbuntuUpdates.org

Package "ubuntu-core-snapd-units"

Name: ubuntu-core-snapd-units

Description:

transitional dummy package

Latest version: 2.48.3+20.04
Release: focal (20.04)
Level: security
Repository: main
Head package: snapd
Homepage: https://github.com/snapcore/snapd

Links


Download "ubuntu-core-snapd-units"


Other versions of "ubuntu-core-snapd-units" in Focal

Repository Area Version
base main 2.44.3+20.04
updates main 2.51.1+20.04ubuntu2

Changelog

Version: 2.48.3+20.04 2021-02-10 01:07:16 UTC

  snapd (2.48.3+20.04) focal-security; urgency=medium

  * SECURITY UPDATE: sandbox escape vulnerability for containers
    (LP: #1910456)
    - many: add Delegate=true to generated systemd units for special
      interfaces
    - interfaces/greengrass-support: back-port interface changes to
      2.48
    - CVE-2020-27352
  * interfaces/builtin/docker-support: allow /run/containerd/s/...
    - This is a new path that docker 19.03.14 (with a new version of
      containerd) uses to avoid containerd CVE issues around the unix
      socket. See also CVE-2020-15257.

Source diff to previous version
CVE-2020-27352 RESERVED
CVE-2020-15257 containerd is an industry-standard container runtime and is available as a daemon for Linux and Windows. In containerd before versions 1.3.9 and 1.4.

Version: 2.45.1+20.04.2 2020-07-15 15:06:33 UTC

  snapd (2.45.1+20.04.2) focal-security; urgency=medium

  * SECURITY UPDATE: sandbox escape vulnerability via snapctl user-open
    (xdg-open)
    - usersession/userd/launcher.go: remove XDG_DATA_DIRS environment
      variable modification when calling the system xdg-open. Patch
      thanks to James Henstridge
    - packaging/ubuntu-16.04/snapd.postinst: kill userd on upgrade so it
      may autostart on next use. Patch thanks to Michael Vogt
    - CVE-2020-11934
    - LP: #1880085

 -- Emilia Torino <email address hidden> Fri, 10 Jul 2020 10:59:20 -0300




About   -   Send Feedback to @ubuntu_updates