UbuntuUpdates.org

Package "openvswitch"

Name: openvswitch

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Open vSwitch public key infrastructure dependency package
  • Open vSwitch test package
  • Simple controller for testing OpenFlow setups
  • Open vSwitch VTEP utilities

Latest version: 2.9.5-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: updates
Repository: universe

Links



Other versions of "openvswitch" in Bionic

Repository Area Version
base universe 2.9.0-0ubuntu1
base main 2.9.0-0ubuntu1
security universe 2.9.2-0ubuntu0.18.04.3
security main 2.9.2-0ubuntu0.18.04.3
updates main 2.9.5-0ubuntu0.18.04.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.9.5-0ubuntu0.18.04.1 2019-12-11 02:06:46 UTC

  openvswitch (2.9.5-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream point release (LP: #1854360).
    - d/p/*: Drop all patches, all upstream.

 -- James Page <email address hidden> Thu, 28 Nov 2019 13:09:13 +0000

Source diff to previous version
1854360 [SRU] openvswitch 2.9.5

Version: 2.9.2-0ubuntu0.18.04.3 2019-01-30 14:07:05 UTC

  openvswitch (2.9.2-0ubuntu0.18.04.3) bionic-security; urgency=medium

  * SECURITY UPDATE: assertion failure when decoding a group mod
    - debian/patches/CVE-2018-17204.patch: don't assert-fail decoding bad
      OF1.5 group mod type or command in lib/ofp-util.c.
    - CVE-2018-17204
  * SECURITY UPDATE: assertion failure when adding flows
    - debian/patches/CVE-2018-17205.patch: fix OVS crash when reverting old
      flows in bundle commit in ofproto/ofproto.c.
    - CVE-2018-17205
  * SECURITY UPDATE: buffer overread during BUNDLE action decoding
    - debian/patches/CVE-2018-17206.patch: avoid overread in
      lib/ofp-actions.c.
    - CVE-2018-17206

 -- Marc Deslauriers <email address hidden> Thu, 25 Oct 2018 09:48:22 -0400

Source diff to previous version
CVE-2018-17204 An issue was discovered in Open vSwitch (OvS) 2.7.x through 2.7.6, affecting parse_group_prop_ntr_selection_method in lib/ofp-util.c. When decoding a
CVE-2018-17205 An issue was discovered in Open vSwitch (OvS) 2.7.x through 2.7.6, affecting ofproto_rule_insert__ in ofproto/ofproto.c. During bundle commit, flows
CVE-2018-17206 An issue was discovered in Open vSwitch (OvS) 2.7.x through 2.7.6. The decode_bundle function inside lib/ofp-actions.c is affected by a buffer over-r

Version: 2.9.2-0ubuntu0.18.04.2 2019-01-28 11:06:33 UTC

  openvswitch (2.9.2-0ubuntu0.18.04.2) bionic; urgency=medium

  * d/p/ovs-compat.patch: Cherry pick fix for missing ovs.compat.*
    modules from upstream VCS, resolving issues with installed
    python{3}-openvswitch modules.
  * d/rules: Disable test 8 on arm64 only avoiding FTBFS on this
    architecure due to transient test failures.




About   -   Send Feedback to @ubuntu_updates