UbuntuUpdates.org

Package "librabbitmq"

Name: librabbitmq

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Command-line utilities for interacting with AMQP servers
  • AMQP client library written in C - Debug Files
  • AMQP client library written in C - Dev Files
  • AMQP client library written in C

Latest version: 0.8.0-1ubuntu0.18.04.2
Release: bionic (18.04)
Level: updates
Repository: universe

Links

Save this URL for the latest version of "librabbitmq": https://www.ubuntuupdates.org/librabbitmq



Other versions of "librabbitmq" in Bionic

Repository Area Version
base universe 0.8.0-1build1
security universe 0.8.0-1ubuntu0.18.04.2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.8.0-1ubuntu0.18.04.2 2019-12-11 18:07:44 UTC

  librabbitmq (0.8.0-1ubuntu0.18.04.2) bionic-security; urgency=medium

  * SECURITY UPDATE: Integer overflow
    - debian/patches/CVE-2019-18609.patch: check frame_size is >= INT32_MAX
      in librabbitmq/amqp_connection.c.
    - CVE-2019-18609

 -- Eduardo Barretto <email address hidden> Tue, 10 Dec 2019 11:09:54 -0300

Source diff to previous version
CVE-2019-18609 An issue was discovered in amqp_handle_input in amqp_connection.c in rabbitmq-c 0.9.0. There is an integer overflow that leads to heap memory corrupt

Version: 0.8.0-1ubuntu0.18.04.1 2019-07-30 17:07:12 UTC

  librabbitmq (0.8.0-1ubuntu0.18.04.1) bionic; urgency=medium

  * d/patches: Add fix-parameter-processing.patch to correct handling of
    --server, --url, and other options by reorganizing the logic flow.
    (LP: #1790657)

 -- Bryce Harrington <email address hidden> Tue, 09 Jul 2019 21:19:59 -0700

1790657 [SRU] amqp-tools server parameter unusable



About   -   Send Feedback to @ubuntu_updates