UbuntuUpdates.org

Package "cyrus-sasl2"

Name: cyrus-sasl2

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Pluggable Authentication Modules for SASL (GSSAPI)
  • Cyrus SASL - pluggable authentication modules (LDAP)
  • Cyrus SASL - pluggable authentication modules (OTP)

Latest version: 2.1.27~101-g0780600+dfsg-3ubuntu2.3
Release: bionic (18.04)
Level: security
Repository: universe

Links



Other versions of "cyrus-sasl2" in Bionic

Repository Area Version
base universe 2.1.27~101-g0780600+dfsg-3ubuntu2
base main 2.1.27~101-g0780600+dfsg-3ubuntu2
security main 2.1.27~101-g0780600+dfsg-3ubuntu2.3
updates universe 2.1.27~101-g0780600+dfsg-3ubuntu2.3
updates main 2.1.27~101-g0780600+dfsg-3ubuntu2.3
proposed universe 2.1.27~101-g0780600+dfsg-3ubuntu2.3

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.1.27~101-g0780600+dfsg-3ubuntu2.3 2021-01-18 21:06:29 UTC

  cyrus-sasl2 (2.1.27~101-g0780600+dfsg-3ubuntu2.3) bionic; urgency=medium

  * d/p/lp-1906627-01-Fix-GSS-SPNEGO-mechanism-s-incompatible-behavior.patch:
    d/p/lp-1906627-02-Drop-unused-parameter-from-gssapi_spnego_ssf.patch:
    - Fix GSS-SPNEGO implementation to be inter-operable with Microsoft
      Active Directory, fixing the source of the recent adcli regression.
      (LP: #1906627)

 -- Matthew Ruffell <email address hidden> Mon, 07 Dec 2020 10:54:47 +1300

Source diff to previous version
1906627 GSS-SPNEGO implementation in cyrus-sasl2 is incompatible with Active Directory, causing recent adcli regression

Version: 2.1.27~101-g0780600+dfsg-3ubuntu2.1 2020-01-28 14:06:51 UTC

  cyrus-sasl2 (2.1.27~101-g0780600+dfsg-3ubuntu2.1) bionic-security; urgency=medium

  * SECURITY UPDATE: Off-by-one
    - debian/patches/CVE-2019-19906.patch: fix in _sasl_add_string function
    - CVE-2019-19906
  * Thanks Debian for the patch provide that (Closes: #947043)

 -- <email address hidden> (Leonidas S. Barbosa) Mon, 27 Jan 2020 16:25:33 -0300

CVE-2019-19906 cyrus-sasl (aka Cyrus SASL) 2.1.27 has an out-of-bounds write leading to unauthenticated remote denial-of-service in OpenLDAP via a malformed LDAP pa



About   -   Send Feedback to @ubuntu_updates