UbuntuUpdates.org

Package "ubuntu-drivers-common"




Name: ubuntu-drivers-common

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • debhelper extension for scanning kernel module aliases
  • transitional package for ubuntu-drivers-common

Latest version: *DELETED*
Release: bionic (18.04)
Level: proposed
Repository: universe

Links

Save this URL for the latest version of "ubuntu-drivers-common": https://www.ubuntuupdates.org/ubuntu-drivers-common



Other versions of "ubuntu-drivers-common" in Bionic

Repository Area Version
base main 1:0.5.2
base universe 1:0.5.2
updates main 1:0.5.2.5
updates universe 1:0.5.2.5
PPA: Mint upstream 1:0.4.17.2linuxmint1
PPA: Mint upstream 1:0.2.91.12linuxmint1
PPA: Mint upstream 1:0.2.91.12linuxmint1
PPA: Mint upstream 1:0.2.91.12linuxmint1
PPA: Mint upstream 1:0.2.91.12linuxmint1
PPA: Mint upstream 1:0.4.17.2linuxmint1
PPA: Mint upstream 1:0.4.17.2linuxmint1
PPA: Mint upstream 1:0.4.17.3linuxmint1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2019-12-19 15:07:11 UTC
No changelog for deleted or moved packages.

Version: 1:0.5.2.5 2019-12-07 02:07:36 UTC

  ubuntu-drivers-common (1:0.5.2.5) bionic; urgency=medium

  * ubuntu-drivers:
    - Make sure that the PATH environment variable is set (LP: #1854472).

 -- Alberto Milone <email address hidden> Mon, 02 Dec 2019 10:31:00 +0100

1854472 ubuntu-drivers-common fails when no PATH environment variable is passed

Version: *DELETED* 2019-12-05 01:07:28 UTC
No changelog for deleted or moved packages.

Version: 1:0.5.2.4 2019-10-05 00:06:53 UTC

  ubuntu-drivers-common (1:0.5.2.4) bionic; urgency=medium

  [ Alberto Milone ]
  * UbuntuDrivers/detect.py,
    UbuntuDrivers/kerneldetection.py,
    tests/ubuntu_drivers.py,
    ubuntu-drivers:
    - Provide DKMS fallback for the "install --gpgpu" case
      when no linux-modules-nvidia are available for the driver
      and for a specific kernel (LP: #1843796).
      We have new tests to cover this scenario now.
    - Show provider of kernel modules in list --gpgpu
    - Fix linux metapackage detection.
      This was meant to be driven by the latest kernel version
      But it was only partially implemented.
      Complete the implementation and update the relevant tests.
    - Make sure to install the linux-modules-nvidia package for the
      kernel flavour in use, when passing the --gpgpu argument, so
      that we can deliver a working NVIDIA installation, provided
      that the EULA was accepted.

  [ Jean-Baptiste Lallement ]
  * ubuntu-drivers,
    UbuntuDrivers/detect.py,
    tests/ubuntu_drivers.py:
    - Add a --free-only parameter, so as to allow installing only the
     available free drivers. This is a backport of only the
     ubuntu-drivers-common specific part of LP: #1819207, since
     it is tied to the rest of the changes to the test suite.
    - Add support for testing against a fake archive with free and
      non-free components.
    - Add static code checker.
  * debian/control:
    - Add pycodestyle and pyflake8 to build depends.

 -- Alberto Milone <email address hidden> Tue, 17 Sep 2019 16:34:56 +0200

1843796 ubuntu-drivers install --gpgpu should use a DKMS fallback when no linux-modules-nvidia package is available

Version: *DELETED* 2019-04-04 06:07:01 UTC
No changelog for deleted or moved packages.



About   -   Send Feedback to @ubuntu_updates