UbuntuUpdates.org

Package "enigmail"

Name: enigmail

Description:

GPG support for Thunderbird and Debian Icedove

Latest version: 2:2.1.2-0ubuntu1~18.04.2
Release: bionic (18.04)
Level: proposed
Repository: universe
Homepage: https://www.enigmail.net/

Links

Save this URL for the latest version of "enigmail": https://www.ubuntuupdates.org/enigmail


Download "enigmail"


Other versions of "enigmail" in Bionic

Repository Area Version
base universe 2:1.9.9-2
security universe 2:2.0.8-1~ubuntu0.18.04.2
updates universe 2:2.0.8-1~ubuntu0.18.04.2
PPA: Ubuntu Mozilla Security 2:2.1.2-0ubuntu1~18.04.2

Changelog

Version: 2:2.1.2-0ubuntu1~18.04.2 2019-11-08 17:06:33 UTC

  enigmail (2:2.1.2-0ubuntu1~18.04.2) bionic; urgency=medium

  * new upstream release
  * do not repack the upstream tarball to strip OpenPGP.js
    - d/copyright
  * remove patches as a consequence:
    - d/patches/0003-avoid-OpenPGP.js-when-building.patch
    - d/patches/0004-copy-enums.armor-from-OpenPGP.js.patch
    - d/patches/0005-avoid-OpenPGP.js-during-key-file-import.patch
    - d/patches/0006-drop-use-of-OpenPGP.js-for-generating-minimal-keys.patch
    - d/patches/0008-enable-the-use-of-extra-file-descriptors-and-test-th.patch
    - d/patches/0009-add-test-to-do-symmetric-encryption-decryption-with-.patch
    - d/patches/0010-use-GnuPG-instead-of-openpgp.js-for-symmetric-encryp.patch
  * refresh patches:
    - d/patches/0001-avoid-eslint-during-buildtest.patch
    - d/patches/0002-Avoid-auto-download-of-pEpEngine-Closes-891882.patch
    - d/patches/0007-add-more-logging-to-autocrypt-test.patch
    - d/patches/0011-tests-wrap-individual-tests-in-key-test-with-withTes.patch
  * new patches:
    - d/patches/0012-fix-stdlib-Makefile.patch
    - d/patches/0013-strip-comment-from-manifest.patch
  * use dh_webext to install the extension
    - d/control
    - d/rules
    - d/run-tests
    - d/install-webext
  * update autopgktests to jsunit API changes
    - d/tests/tbird-sqlite{,.js}
    - d/tests/unit-tests
  * downgrade build dependency on debhelper to 11, because 12 is not in bionic
    - d/control
  * downgrade runtime dependency on gnupg to 2.0.14, which is what enigmail
    really defines as the minimum supported version (MINIMUM_GPG_VERSION)
    - d/control

 -- Olivier Tilloy <email address hidden> Thu, 31 Oct 2019 14:57:22 +0100




About   -   Send Feedback to @ubuntu_updates