UbuntuUpdates.org

Package "nvidia-dkms-390"

Name: nvidia-dkms-390

Description:

NVIDIA DKMS package

Latest version: 390.157-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: security
Repository: restricted
Head package: nvidia-graphics-drivers-390
Homepage: http://www.nvidia.com

Links


Download "nvidia-dkms-390"


Other versions of "nvidia-dkms-390" in Bionic

Repository Area Version
updates restricted 390.157-0ubuntu0.18.04.1
PPA: Canonical Kernel Team 390.138-0ubuntu0.18.04.1

Changelog

Version: 390.143-0ubuntu0.18.04.1 2021-04-23 21:06:20 UTC

  nvidia-graphics-drivers-390 (390.143-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1923062).
  * debian/templates/dkms_nvidia.conf.in:
    - Drop buildfix_kernel_5.11.patch.

 -- Alberto Milone <email address hidden> Fri, 09 Apr 2021 17:13:11 +0200

Source diff to previous version

Version: 390.141-0ubuntu0.18.04.2 2021-04-14 20:07:37 UTC

  nvidia-graphics-drivers-390 (390.141-0ubuntu0.18.04.2) bionic; urgency=medium

  * debian/templates/control.in:
    - Add conflicts/replace/provides for all the metapackages
      (LP: #1915935).
    - Add XB-Support field and set it to "Legacy".
  * debian/templates/dkms_nvidia.conf.in,
    debian/dkms_nvidia/patches/buildfix_kernel_5.11.patch:
    - Add support for Linux 5.11 (LP: #1916908).
      Note: UVM is disabled for Linux >= 5.10.

 -- Alberto Milone <email address hidden> Thu, 25 Feb 2021 17:07:58 +0100

Source diff to previous version

Version: 390.141-0ubuntu0.18.04.1 2021-01-11 19:07:00 UTC

  nvidia-graphics-drivers-390 (390.141-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1906680):
    - CVE-2021-1052, CVE-2021-1053.

 -- Alberto Milone <email address hidden> Tue, 05 Jan 2021 13:56:31 +0100

Source diff to previous version
CVE-2021-1052 RESERVED
CVE-2021-1053 RESERVED

Version: 390.138-0ubuntu0.18.04.1 2020-06-25 11:07:08 UTC

  nvidia-graphics-drivers-390 (390.138-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release (LP: #1882093):
    - CVE-2020-5963, CVE-2020-5967.
  * debian/templates/control.in:
    - make the DKMS dependency less strict.
    - Use versioned dependencies on nvidia-kernel-common and
      nvidia-dkms, to keep user space in sync with the kernel modules.
  * debian/templates/dkms_nvidia.conf.in:
    - Drop do-not-call-pci_save_state.patch.
  * debian/rules:
    - expose DEBIAN_VERSION.

 -- Alberto Milone <email address hidden> Wed, 17 Jun 2020 11:34:40 +0200

Source diff to previous version
CVE-2020-5963 RESERVED
CVE-2020-5967 RESERVED

Version: 390.116-0ubuntu0.18.04.1 2019-03-07 16:06:56 UTC

  nvidia-graphics-drivers-390 (390.116-0ubuntu0.18.04.1) bionic; urgency=medium

  * SECURITY UPDATE:
    - CVE‑2018‑6260 (LP: #1814548).
  * New upstream release:
    - Fixed build failures which resulted in errors like "implicit
      declaration of function drm_...", when building the NVIDIA
      DRM kernel module for Linux kernel 5.0 release candidates.
    - Fixed a bug which could cause VK_KHR_external_semaphore_fd
      operations to fail.
    - Fixed a build failure, "implicit declaration of function
      'vm_insert_pfn'", when building the NVIDIA DRM kernel module
      for Linux kernel 4.20 release candidates.
    - Fixed a build failure, "unknown type name 'ipmi_user_t'",
      when building the NVIDIA kernel module for Linux kernel 4.20
      release candidates.
    - Fixed a bug that caused mode switches to fail when an SDI
      output board was connected.
    - Fixed a bug that could cause rendering corruption in Vulkan
      programs.
    - Fixed a bug that caused
      vkGetPhysicalDeviceDisplayPropertiesKHR() to occasionally
      return incorrect values for physicalResolution.
    - Added the synchronization state for PRIME Displays to nvidia-
      settings.
    - Fixed a bug that could prevent nvidia-xconfig from disabling
      the X Composite extension on version 1.20 of the X.org X
      server.
    - Fixed a build failure, "too many arguments to function
      'get_user_pages'", when building the NVIDIA kernel module for
      Linux kernel v4.4.168.
    - Fixed a build failure, "implicit declaration of function
      do_gettimeofday", when building the NVIDIA kernel module for
      Linux kernel 5.0 release candidates.
    - Added a new kernel module parameter,
      NVreg_RestrictProfilingToAdminUsers, to allow restricting the
      use of GPU performance counters to system administrators
      only.

 -- Alberto Milone <email address hidden> Mon, 25 Feb 2019 12:10:20 +0100

1814548 CVE-2018-6260



About   -   Send Feedback to @ubuntu_updates