UbuntuUpdates.org

Package "libglib2.0-doc"

Name: libglib2.0-doc

Description:

Documentation files for the GLib library

Latest version: 2.56.4-0ubuntu0.18.04.5
Release: bionic (18.04)
Level: proposed
Repository: main
Head package: glib2.0
Homepage: http://www.gtk.org/

Links

Save this URL for the latest version of "libglib2.0-doc": https://www.ubuntuupdates.org/libglib2.0-doc


Download "libglib2.0-doc"


Other versions of "libglib2.0-doc" in Bionic

Repository Area Version
base main 2.56.1-2ubuntu1
security main 2.56.4-0ubuntu0.18.04.4
updates main 2.56.4-0ubuntu0.18.04.4

Changelog

Version: 2.56.4-0ubuntu0.18.04.5 2019-11-21 16:07:11 UTC

  glib2.0 (2.56.4-0ubuntu0.18.04.5) bionic; urgency=medium

  [ Gunnar Hjalmarsson ]
  * d/p/gcredentialsprivate-Document-the-various-private-macros.patch,
    d/p/credentials-Invalid-Linux-struct-ucred-means-no-informati.patch,
    d/p/GDBus-prefer-getsockopt-style-credentials-passing-APIs.patch:
    - Ensure libdbus clients can authenticate with a GDBusServer like
      the one in ibus. The patches cherry picked from 2.62.2-2 in focal
      in order to allow the ibus fix of CVE-2019-14822 to be re-enabled
      without breaking ibus for Qt applications (LP: #1844853).

  [ Iain Lane ]
  * d/p/Add-a-test-for-GDBusServer-authentication.patch: Additionally backport
    this commit to add a test for the above fixes.
    + BD on libdbus-1-dev so that the above test gets run properly.

 -- Gunnar Hjalmarsson <email address hidden> Thu, 31 Oct 2019 00:16:00 +0100

1844853 IBus no longer works in Qt applications after upgrade
CVE-2019-14822 missing authorization flaw

Version: *DELETED* 2019-05-02 12:07:52 UTC
No changelog for deleted or moved packages.

Version: 2.56.4-0ubuntu0.18.04.2 2019-03-22 14:07:04 UTC

  glib2.0 (2.56.4-0ubuntu0.18.04.2) bionic; urgency=medium

  * Backport upstream patches to fix GVariant alignment tests
    d/p/gvariant-test-Also-force-alignment-for-tuple-test-data.patch,
    d/p/tests-Allocate-gvariant-data-from-the-heap-to-guarantee-a.patch:
    Cherry-pick.


Version: *DELETED* 2018-11-14 08:17:02 UTC
No changelog for deleted or moved packages.

Version: 2.56.3-0ubuntu0.18.04.1 2018-10-22 16:06:39 UTC

  glib2.0 (2.56.3-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1794544)
    + The documentation for G_GNUC_MALLOC has changed to be more restrictive
      to avoid miscompilations; you should check whether any uses of it in
      your code are appropriate
    + Fix cancellation of g_subprocess_communicate_async() calls
    + Bug fixes:
      + /network-monitor/create-in-thread fails in (LXC) containers on glib-2-56
      + GBookmarkFile: nullptr access in current_element
      + GBookmarkFile: heap-buffer-overflow in g_utf8_get_char
      + Backport g_subprocess_communicate() cancellation fixes from !266 to
        glib-2-56 (LP: #1789476)
      + Many uses of G_GNUC_MALLOC are incorrect
      + Test for BROKEN_IP_MREQ_SOURCE_STRUCT is broken on Windows / Mingw
      + Fix persistent CI failure on glib-2-56
  * debian/watch: Only find 2.56 versions.
  * Drop CVE-2018-16428.patch and CVE-2018-16429.patch: applied in this release

 -- Iain Lane <email address hidden> Wed, 26 Sep 2018 17:35:59 +0100

1794544 [SRU] 2.56.3
1789476 glib apps using GSubprocess communicate might crash on g_subprocess_communicate_cancelled
CVE-2018-16428 In GNOME GLib 2.56.1, g_markup_parse_context_end_parse() in gmarkup.c has a NULL pointer dereference.
CVE-2018-16429 GNOME GLib 2.56.1 has an out-of-bounds read vulnerability in g_markup_parse_context_parse() in gmarkup.c, related to utf8_str().



About   -   Send Feedback to @ubuntu_updates