UbuntuUpdates.org

Package "ruby2.4"

This package belongs to a PPA: Brightbox Ruby NG Experimental

Name: ruby2.4

Description:

Interpreter of object-oriented scripting language Ruby

Latest version: 2.4.5-1bbox2~xenial1
Release: xenial (16.04)
Level: base
Repository: main

Links

Save this URL for the latest version of "ruby2.4": https://www.ubuntuupdates.org/ruby2.4


Download "ruby2.4"


Other versions of "ruby2.4" in Xenial

No other version of this package is available in the Xenial release.

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.4.5-1bbox2~xenial1 2018-10-22 20:08:38 UTC

 ruby2.4 (2.4.5-1bbox2~xenial1) xenial; urgency=medium
 .
   * New upstream release, 2.4.5.
   * Fix baseruby detection for building on bionic
   * Fixes CVE-2018-16396 and CVE-2018-16395.

Source diff to previous version
CVE-2018-16396 RESERVED
CVE-2018-16395 RESERVED

Version: 2.4.5-1bbox1~xenial1 2018-10-22 19:09:07 UTC

 ruby2.4 (2.4.5-1bbox1~xenial1) xenial; urgency=medium
 .
   * New upstream release, 2.4.5.
   * Fix openssl dependency on >= Bionic. Requires 1.0.
   * Fixes CVE-2018-16396 and CVE-2018-16395.

Source diff to previous version
CVE-2018-16396 RESERVED
CVE-2018-16395 RESERVED

Version: 2.4.4-1bbox1~xenial1 2018-04-09 13:08:18 UTC

 ruby2.4 (2.4.4-1bbox1~xenial1) xenial; urgency=medium
 .
   * New upstream release, 2.4.4

Source diff to previous version

Version: 2.4.3-1bbox1~xenial1 2018-01-12 20:09:03 UTC

 ruby2.4 (2.4.3-1bbox1~xenial1) xenial; urgency=medium
 .
   * New upstream release, 2.4.3

Source diff to previous version

Version: 2.4.2-1bbox1~xenial2 2017-11-13 17:08:08 UTC

 ruby2.4 (2.4.2-1bbox1~xenial2) xenial; urgency=low
 .
   * Ignore explicit_bzero symbol to fix building on Artful




About   -   Send Feedback to @ubuntu_updates