UbuntuUpdates.org

Package "ruby2.3"

This package belongs to a PPA: Brightbox Ruby NG Experimental

Name: ruby2.3

Description:

Interpreter of object-oriented scripting language Ruby

Latest version: 2.3.8-4bbox1~xenial1
Release: xenial (16.04)
Level: base
Repository: main

Links

Save this URL for the latest version of "ruby2.3": https://www.ubuntuupdates.org/ruby2.3


Download "ruby2.3"


Other versions of "ruby2.3" in Xenial

Repository Area Version
base universe 2.3.0-5ubuntu1
base main 2.3.0-5ubuntu1
security universe 2.3.1-2~16.04.12
security main 2.3.1-2~16.04.12
updates main 2.3.1-2~ubuntu16.04.13
updates universe 2.3.1-2~ubuntu16.04.13

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.3.8-4bbox1~xenial1 2018-10-26 13:09:41 UTC

 ruby2.3 (2.3.8-4bbox1~xenial1) xenial; urgency=medium
 .
   * build with gcc-6 on bionic rather than gcc-7

Source diff to previous version

Version: 2.3.8-3bbox1~xenial1 2018-10-24 17:08:44 UTC

 ruby2.3 (2.3.8-3bbox1~xenial1) xenial; urgency=medium
 .
   * build with gcc-6 on bionic rather than gcc-7

Source diff to previous version

Version: 2.3.8-2bbox1~xenial1 2018-10-22 19:09:07 UTC

 ruby2.3 (2.3.8-2bbox1~xenial1) xenial; urgency=medium
 .
   * new upstream release, 2.3.8.
   * Fixes CVE-2018-16396 and CVE-2018-16395.
   * Fix openssl dependency on >= Bionic. Requires 1.0.

Source diff to previous version
CVE-2018-16396 RESERVED
CVE-2018-16395 RESERVED

Version: 2.3.8-1bbox1~xenial1 2018-10-22 17:08:30 UTC

 ruby2.3 (2.3.8-1bbox1~xenial1) xenial; urgency=medium
 .
   * new upstream release, 2.3.8. Fixes CVE-2018-16396 and
     CVE-2018-16395.
   * Fix openssl dependency on >= Bionic. Requires 1.0.

Source diff to previous version
CVE-2018-16396 RESERVED
CVE-2018-16395 RESERVED

Version: 2.3.7-1bbox1~xenial1 2018-04-06 18:08:40 UTC

 ruby2.3 (2.3.7-1bbox1~xenial1) xenial; urgency=medium
 .
   * new upstream release, 2.3.7




About   -   Send Feedback to @ubuntu_updates