UbuntuUpdates.org

Package "libruby1.8-dbg"

This package belongs to a PPA: Brightbox Ruby NG Experimental

Name: libruby1.8-dbg

Description:

Debugging symbols for Ruby 1.8

Latest version: 1:1.8.7.376-377bbox1~xenial1
Release: xenial (16.04)
Level: base
Repository: main
Head package: ruby1.8

Links

Save this URL for the latest version of "libruby1.8-dbg": https://www.ubuntuupdates.org/libruby1.8-dbg


Download "libruby1.8-dbg"


Other versions of "libruby1.8-dbg" in Xenial

No other version of this package is available in the Xenial release.

Changelog

Version: 1:1.8.7.376-377bbox1~xenial1 2018-01-17 15:08:06 UTC

 ruby1.8 (1:1.8.7.376-377bbox1~xenial1) xenial; urgency=medium
 .
   * Backported fixes for CVE-2017-17405 Net::FTP
   * Backported Unsafe Object Deserialization Vulnerability in RubyGems

Source diff to previous version
CVE-2017-17405 Ruby before 2.4.3 allows Net::FTP command injection. Net::FTP#get, getbinaryfile, gettextfile, put, putbinaryfile, and puttextfile use Kernel#open to

Version: 1:1.8.7.376-1bbox8~xenial1 2017-11-06 19:10:11 UTC

 ruby1.8 (1:1.8.7.376-1bbox8~xenial1) xenial; urgency=medium
 .
   * Use /var/lib/gems for gem installation
   * Disable system gem updater

Source diff to previous version

Version: 1:1.8.7.376-1bbox6~xenial1 2017-09-27 15:07:37 UTC

 ruby1.8 (1:1.8.7.376-1bbox6~xenial1) xenial; urgency=low
 .
   * Bump version to rebuild

Source diff to previous version

Version: 1:1.8.7.376-1bbox4~ubuntu16.04.1~ppa1 2017-04-28 10:08:10 UTC

 ruby1.8 (1:1.8.7.376-1bbox4~ubuntu16.04.1~ppa1) xenial; urgency=medium
 .
   * No-change backport to xenial

Source diff to previous version

Version: 1:1.8.7.375-1bbox1~xenial2 2016-06-27 06:55:54 UTC

 ruby1.8 (1:1.8.7.375-1bbox1~xenial2) xenial; urgency=low
 .
   * Fix compiling with newer zlib




About   -   Send Feedback to @ubuntu_updates