UbuntuUpdates.org

Package "libruby2.4"

This package belongs to a PPA: Brightbox Ruby NG Experimental

Name: libruby2.4

Description:

Libraries necessary to run Ruby 2.4

Latest version: 2.4.9-1bbox1~bionic1
Release: bionic (18.04)
Level: base
Repository: main
Head package: ruby2.4

Links

Save this URL for the latest version of "libruby2.4": https://www.ubuntuupdates.org/libruby2.4


Download "libruby2.4"


Other versions of "libruby2.4" in Bionic

No other version of this package is available in the Bionic release.

Changelog

Version: 2.4.9-1bbox1~bionic1 2019-10-03 18:08:37 UTC

 ruby2.4 (2.4.9-1bbox1~bionic1) bionic; urgency=medium
 .
   * New upstream release, 2.4.9
   * Fixes CVE-2019-16255, CVE-2019-16254, CVE-2019-15845, CVE-2019-16201,
     CVE-2012-6708, CVE-2015-9251

Source diff to previous version
CVE-2019-16255 RESERVED
CVE-2019-16254 RESERVED
CVE-2019-15845 RESERVED
CVE-2019-16201 RESERVED
CVE-2012-6708 jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in
CVE-2015-9251 jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, ca

Version: 2.4.6-1bbox1~bionic1 2019-04-15 16:08:47 UTC

 ruby2.4 (2.4.6-1bbox1~bionic1) bionic; urgency=medium
 .
   * New upstream release, 2.4.6
   * Fixes multiple rubygems security bugs, CVE-2019-8320 through 8325

Source diff to previous version
CVE-2019-8320 RESERVED

Version: 2.4.5-1bbox4~bionic1 2019-01-03 18:07:23 UTC

 ruby2.4 (2.4.5-1bbox4~bionic1) bionic; urgency=medium
 .
   * New upstream release, 2.4.5.
   * Fix baseruby detection for building on bionic
   * Fixes CVE-2018-16396 and CVE-2018-16395.

Source diff to previous version
CVE-2018-16396 RESERVED
CVE-2018-16395 RESERVED

Version: 2.4.5-1bbox2~bionic1 2018-10-22 20:08:38 UTC

 ruby2.4 (2.4.5-1bbox2~bionic1) bionic; urgency=medium
 .
   * New upstream release, 2.4.5.
   * Fix baseruby detection for building on bionic
   * Fixes CVE-2018-16396 and CVE-2018-16395.

Source diff to previous version
CVE-2018-16396 RESERVED
CVE-2018-16395 RESERVED

Version: 2.4.5-1bbox1~bionic1 2018-10-22 19:09:08 UTC

 ruby2.4 (2.4.5-1bbox1~bionic1) bionic; urgency=medium
 .
   * New upstream release, 2.4.5.
   * Fix openssl dependency on >= Bionic. Requires 1.0.
   * Fixes CVE-2018-16396 and CVE-2018-16395.

CVE-2018-16396 RESERVED
CVE-2018-16395 RESERVED



About   -   Send Feedback to @ubuntu_updates