UbuntuUpdates.org

Bugs fixes in "cups"

Origin Bug number Title Date fixed
CVE CVE-2018-6553 AppArmor profile issue in cups 2018-07-11
CVE CVE-2018-4181 Limited Local File Reads as Root via cupsd.conf Include Directive 2018-07-11
CVE CVE-2018-4180 Local Privilege Escalation to Root in dnssd Backend (CUPS_SERVERBIN) 2018-07-11
CVE CVE-2017-18248 The add_job function in scheduler/ipp.c in CUPS before 2.2.6, when D-Bus support is enabled, can be crashed by remote attackers by sending print jobs 2018-07-11
CVE CVE-2018-6553 AppArmor profile issue in cups 2018-07-11
CVE CVE-2018-4181 Limited Local File Reads as Root via cupsd.conf Include Directive 2018-07-11
CVE CVE-2018-4180 Local Privilege Escalation to Root in dnssd Backend (CUPS_SERVERBIN) 2018-07-11
CVE CVE-2018-6553 AppArmor profile issue in cups 2018-07-11
CVE CVE-2018-4181 Limited Local File Reads as Root via cupsd.conf Include Directive 2018-07-11
CVE CVE-2018-4180 Local Privilege Escalation to Root in dnssd Backend (CUPS_SERVERBIN) 2018-07-11
CVE CVE-2017-18190 A localhost.localdomain whitelist entry in valid_host() in scheduler/client.c in CUPS before 2.2.2 allows remote attackers to execute arbitrary IPP c 2018-02-21
CVE CVE-2017-18190 A localhost.localdomain whitelist entry in valid_host() in scheduler/client.c in CUPS before 2.2.2 allows remote attackers to execute arbitrary IPP c 2018-02-21
CVE CVE-2017-18190 A localhost.localdomain whitelist entry in valid_host() in scheduler/client.c in CUPS before 2.2.2 allows remote attackers to execute arbitrary IPP c 2018-02-21
CVE CVE-2017-18190 A localhost.localdomain whitelist entry in valid_host() in scheduler/client.c in CUPS before 2.2.2 allows remote attackers to execute arbitrary IPP c 2018-02-21
CVE CVE-2017-18190 A localhost.localdomain whitelist entry in valid_host() in scheduler/client.c in CUPS before 2.2.2 allows remote attackers to execute arbitrary IPP c 2018-02-21
CVE CVE-2017-18190 A localhost.localdomain whitelist entry in valid_host() in scheduler/client.c in CUPS before 2.2.2 allows remote attackers to execute arbitrary IPP c 2018-02-21
Launchpad 1642966 package cups-daemon 2.1.3-4 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1 2017-03-27
Launchpad 1642966 package cups-daemon 2.1.3-4 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1 2017-03-27
Launchpad 1665018 client tools ignore -h option without port number 2017-02-28
Launchpad 1665018 client tools ignore -h option without port number 2017-02-17



About   -   Send Feedback to @ubuntu_updates