UbuntuUpdates.org

Package "cargo"

This package belongs to a PPA: Ubuntu Mozilla Security

Name: cargo

Description:

Rust package manager

Latest version: 0.31.0-3ubuntu1~14.04.1
Release: trusty (14.04)
Level: base
Repository: main

Links

Save this URL for the latest version of "cargo": https://www.ubuntuupdates.org/cargo


Download "cargo"


Other versions of "cargo" in Trusty

Repository Area Version
security universe 0.31.0-3ubuntu1~14.04.1
updates universe 0.31.0-3ubuntu1~14.04.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.31.0-3ubuntu1~14.04.1 2018-12-05 16:08:02 UTC

 cargo (0.31.0-3ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 0.31.0 to trusty
   * Embed libgit2 0.27.0 to avoid a dependency on a version which is newer
     than that found in bionic
     - add debian/libgit2
     - add debian/patches/do-not-use-system-libgit2.patch
     - update debian/control
     - update debian/rules
     - update debian/copyright
     - update debian/patches/series
     - update debian/README.source
   * Hack the libgit2-sys build process to link the bundled libgit2
     against the system's libhttp_parser.
     - add debian/patches/use-system-libhttp-parser.patch
     - update debian/patches/series
   * Drop ssh_key_from_memory from the git2 default features, as that results
     in the libgit2 build depending on a version of libssh2 that is too recent
     - add debian/patches/git2-no-ssh_key_from_memory.patch
     - update debian/patches/series
   * Relax debhelper and dpkg-dev requirements
     - update debian/control
   * Update cargo wrapper to be compatible with the version of Python 3 found
     in trusty.
     - update debian/bin/cargo
   * Don't use the multi-arch pkg-config (by reverting debian patch to
     vendor/pkg-config).
     - add debian/patches/do-not-use-multiarch-pkg-config.patch
     - update debian/patches/series

Source diff to previous version

Version: 0.29.0-1ubuntu1~14.04.1 2018-10-16 18:08:16 UTC

 cargo (0.29.0-1ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 0.29.0 to xenial
   * Embed libgit2 0.27.0 to avoid a dependency on a version which is newer
     than that found in bionic
     - add debian/libgit2
     - update debian/control
     - update debian/rules
     - update debian/copyright
     - update debian/patches/series
     - update debian/README.source
   * Drop ssh_key_from_memory from the git2 default features, as that results
     in the libgit2 build depending on a version of libssh2 that is too recent
     - add debian/patches/git2-no-ssh_key_from_memory.patch
     - update debian/patches/series
   * Relax debhelper and dpkg-dev requirements
     - update debian/control
   * Don't use the multi-arch pkg-config
     - update debian/rules


Version: *DELETED* 2018-09-17 14:08:50 UTC
No changelog for deleted or moved packages.

Version: 0.26.0-0ubuntu2~14.04.1 2018-07-03 10:09:30 UTC

 cargo (0.26.0-0ubuntu2~14.04.1) trusty; urgency=medium
 .
   * Backport 0.26.0 to trusty
 .
   * Embed libgit2 0.25.1 to avoid a dependency on a version which is newer
     than that found in Ubuntu. Do this in debian/ rather than just not
     omitting it from the tarball so that we can share Debian's tarball
     - add debian/libgit2
     - update debian/control
     - update debian/rules
     - update debian/copyright
     - update debian/patches/series
     - update debian/README.source
   * Relax debhelper and dpkg-dev requirements
   * Don't use the multi-arch pkg-config
     - update debian/rules

Source diff to previous version

Version: 0.25.0-1ubuntu1~14.04.1 2018-05-09 20:08:54 UTC

 cargo (0.25.0-1ubuntu1~14.04.1) trusty; urgency=medium
 .
   [ Rico Tzschichholz ]
   * Backport 0.25.0 to trusty
 .
   * Embed libgit2 0.25.1 to avoid a dependency on a version which is newer
     than that found in Ubuntu. Do this in debian/ rather than just not
     omitting it from the tarball so that we can share Debian's tarball
     - add debian/libgit2
     - update debian/control
     - update debian/rules
     - update debian/copyright
     - update debian/patches/series
     - update debian/README.source
   * Relax debhelper and dpkg-dev requirements
   * Don't use the multi-arch pkg-config
     - update debian/rules




About   -   Send Feedback to @ubuntu_updates