UbuntuUpdates.org

Package "cargo"

This package belongs to a PPA: Ubuntu Mozilla Security

Name: cargo

Description:

Rust package manager

Latest version: 0.26.0-0ubuntu2~17.10.1
Release: artful (17.10)
Level: base
Repository: main

Links

Save this URL for the latest version of "cargo": https://www.ubuntuupdates.org/cargo


Download "cargo"


Other versions of "cargo" in Artful

Repository Area Version
base universe 0.19.0-0ubuntu1
security universe 0.26.0-0ubuntu2~17.10.1
updates universe 0.26.0-0ubuntu2~17.10.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.26.0-0ubuntu2~17.10.1 2018-07-03 10:09:31 UTC

 cargo (0.26.0-0ubuntu2~17.10.1) artful; urgency=medium
 .
   * Backport 0.26.0 to artful
 .
   * Embed libgit2 0.25.1 to avoid a dependency on a version which is newer
     than that found in Ubuntu. Do this in debian/ rather than just not
     omitting it from the tarball so that we can share Debian's tarball
     - add debian/libgit2
     - update debian/control
     - update debian/rules
     - update debian/copyright
     - update debian/patches/series
     - update debian/README.source

Source diff to previous version

Version: 0.25.0-1ubuntu1~17.10.1 2018-05-09 20:08:55 UTC

 cargo (0.25.0-1ubuntu1~17.10.1) artful; urgency=medium
 .
   [ Rico Tzschichholz ]
   * Backport 0.25.0 to artful
 .
   * Embed libgit2 0.25.1 to avoid a dependency on a version which is newer
     than that found in Ubuntu. Do this in debian/ rather than just not
     omitting it from the tarball so that we can share Debian's tarball
     - add debian/libgit2
     - update debian/control
     - update debian/rules
     - update debian/copyright
     - update debian/patches/series
     - update debian/README.source

Source diff to previous version

Version: 0.23.0-0ubuntu0.17.10.1 2018-03-13 00:08:31 UTC

 cargo (0.23.0-0ubuntu0.17.10.1) artful; urgency=medium
 .
   * Update to 0.23.0
 .
   * Refresh patches
     - update debian/patches/2004_clean-cargo-deps.patch
   * Drop patches that are fixed upstream
     - remove debian/patches/1001_fix_spelling_errors.patch
     - update debian/patches/series
   * Don't strip libgit2 from the tarball
     - update debian/vendor-tarball-filter.txt
     - remove debian/libgit2
     - update debian/rules
     - update debian/copyright
   * Don't depend on mdbook when generating the documentation, as nothing in
     the archive provides it and it isn't needed
     - add debian/patches/dont-depend-on-mdbook.patch
     - update debian/patches/series

Source diff to previous version

Version: 0.22.0-0ubuntu0.17.10.1 2018-01-22 22:08:24 UTC

 cargo (0.22.0-0ubuntu0.17.10.1) artful; urgency=medium
 .
   * Update to 0.22.0
 .
   * Refresh patches
     - update debian/patches/2004_clean-cargo-deps.patch
   * Drop debian/patches/fix-libc-build-on-s390x.patch - fixed upstream
 .

Source diff to previous version

Version: 0.20.0-2ubuntu3 2017-11-09 23:08:51 UTC

 cargo (0.20.0-2ubuntu3) artful; urgency=medium
 .
   * Merge from Debian, remaining changes:
     - Don't use the bootstrap.py script for bootstrapping as it no longer
       works.
       + remove debian/bootstrap.py
       + update debian/control
       + update debian/rules
       + update debian/make_orig_multi.sh
     - Embed libgit2 0.25.1 to avoid a dependency on a version which is newer
       than that found in Ubuntu. Do this in debian/ rather than just not
       omitting it from the tarball so that we can share Debian's tarball
       + add debian/libgit2
       + update debian/control
       + update debian/rules
       + update debian/copyright
     - Ignore test failures on s390x. There's no Debian build yet on this
       arch and there's nothing in the archive that requires cargo on s390x yet
       + update debian/rules




About   -   Send Feedback to @ubuntu_updates