UbuntuUpdates.org

Package "gnome-software"




Name: gnome-software

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Transitional package (gnome-packagekit-session -> gnome-software)
  • Flatpak support for GNOME Software
  • Limba support for GNOME Software

Latest version: *DELETED*
Release: zesty (17.04)
Level: proposed
Repository: universe

Links

Save this URL for the latest version of "gnome-software": https://www.ubuntuupdates.org/gnome-software



Other versions of "gnome-software" in Zesty

Repository Area Version
base universe 3.22.7-0ubuntu3
base main 3.22.7-0ubuntu3
updates universe 3.22.7-0ubuntu3.17.04.8
updates main 3.22.7-0ubuntu3.17.04.8

Packages in group

Deleted packages are displayed in grey.

gnome-packagekit-session gnome-software-plugin-flatpak gnome-software-plugin-limba

Changelog

Version: *DELETED* 2017-12-20 00:07:00 UTC
No changelog for deleted or moved packages.

Version: 3.22.7-0ubuntu3.17.04.8 2017-12-07 23:06:43 UTC

  gnome-software (3.22.7-0ubuntu3.17.04.8) zesty; urgency=medium

  * debian/patches/0001-snap-Protect-store-cache-with-a-lock.patch:
    - Fix crash due to multiple threads accessing a cache (LP: #1716633)
  * debian/patches/0001-snap-Don-t-attempt-to-refine-snaps-without-a-valid-n.patch:
    - Fix potential crash from invalid snaps
  * debian/patches/0001-snap-Fix-leak-of-GsApp.patch:
    - Fix small memory leak
  * debian/patches/0001-snap-Only-show-snaps-as-sandboxed-if-snapd-supports-.patch:
    - Simple patch added to make above patches apply cleanly
  * debian/patches/0001-snap-Cancel-snapd-transaction-when-install-remove-ca.patch:
  * debian/patches/0001-snap-Generate-correct-error-for-cancelled-operations.patch:
    - Abort change in snapd when install/remove cancelled (LP: #1721762)
  * debian/patches/0022-snap-Use-new-Polkit-API.patch:
    - Send Polkit interactive header (LP: #1736232)
  * debian/patches/0023-snap-Support-new-snapd-license-field.patch
    - Show license field (not yet supported by Ubuntu Store / snaps)
  * debian/patches/0024-Use-the-developer-name-if-set-in-preference-to-the-p.patch:
  * debian/patches/0025-snap-Use-developer-field.patch
    - Show snap developer (LP: #1715054)
  * debian/patches/0026-snap-Correct-the-app-origin.patch:
    - Set correct store name (LP: #1706500)

 -- Robert Ancell <email address hidden> Wed, 06 Dec 2017 10:37:25 +1300

1716633 Installed, popular and featured snaps are loaded in parallel threads can crash
1721762 Cancelled installation of snap continues
1736232 GNOME Software shows U1 login for snaps
1715054 Developer name not shown for snaps
1706500 Update snap store name \

Version: *DELETED* 2017-09-06 10:06:30 UTC
No changelog for deleted or moved packages.

Version: 3.22.7-0ubuntu3.17.04.7 2017-08-24 21:06:42 UTC

  gnome-software (3.22.7-0ubuntu3.17.04.7) zesty; urgency=medium

  * debian/patches/0001-snap-Use-title-field-if-available.patch:
    - Use new title field from snapd (LP: #1555569)
  * debian/patches/0001-snap-Remove-size-limit-on-snap-responses.patch:
  * debian/patches/0002-snap-Fix-failures-to-read-from-snapd.patch:
    - Fix icons larger than 65kB not loading (LP: #1704888)
  * debian/patches/0001-snap-Mark-non-app-snaps-as-runtimes.patch:
    - Stop 'core' snap showing as an app (LP: #1704904)
  * debian/patches/0001-snap-Fix-crash-when-fail-to-use-icon-from-cache.patch:
    - Add to debian/patches/series - was not enabled in last release
  * debian/patches/0001-snap-Replace-libsoup-icon-loading-code-with-AsIcon.patch:
    - Fix crash loading cached icons (LP: #1708140)
  * debian/patches/0001-snap-Run-before-hardcoded-popular-plugin.patch:
  * debian/patches/0018-Make-gs_app_list_filter_duplicates-not-change-app-or.patch:
  * debian/patches/0019-snap-Use-first-featured-snap-as-featured-app.patch:
  * debian/patches/0020-snap-Only-feature-snaps.patch:
  * debian/patches/0021-Don-t-randomize-editors-picks.patch:
    - Only show snaps in "Editor's picks" (LP: #1705953)
    - Show snap in "Featured" section (LP: #1706478)

Source diff to previous version

Version: 3.22.7-0ubuntu3.17.04.6 2017-07-13 18:07:21 UTC

  gnome-software (3.22.7-0ubuntu3.17.04.6) zesty; urgency=medium

  * 0001-snap-Fix-crash-when-fail-to-use-icon-from-cache.patch:
    - Fix crash when failing to load icons from cache (LP: #1702122)

 -- Robert Ancell <email address hidden> Wed, 12 Jul 2017 16:45:03 +1200

1702122 /usr/bin/gnome-software:11:load_icon:gs_plugin_refine_app:gs_plugin_loader_run_refine_app:gs_plugin_loader_run_refine_internal:gs_plugin_loader_run_r



About   -   Send Feedback to @ubuntu_updates