UbuntuUpdates.org

Package "update-manager"

Name: update-manager

Description:

GNOME application that manages apt updates

Latest version: 1:17.04.8
Release: zesty (17.04)
Level: updates
Repository: main

Links

Save this URL for the latest version of "update-manager": https://www.ubuntuupdates.org/update-manager


Download "update-manager"


Other versions of "update-manager" in Zesty

Repository Area Version
base main 1:17.04.3
base universe 1:17.04.3
updates universe 1:17.04.8

Packages in group

Deleted packages are displayed in grey.

python3-update-manager update-manager-core

Changelog

Version: 1:17.04.8 2017-10-31 21:07:24 UTC

  update-manager (1:17.04.8) zesty; urgency=medium

  * UpdateManager/UpdatesAvailable.py: Provide instructions when mount points
    have insufficient free space for the upgrade to complete. (LP: #1477455)
  * test_update_origin.py: fix the extended origin matcher test as it was
    making wrong assumptions, not checking if packages actually had ANY package
    in -security. This should fix the current autopkgtest failures.
    (LP: #1717360)

 -- Brian Murray <email address hidden> Wed, 20 Sep 2017 14:36:07 -0700

Source diff to previous version
1477455 Incorrect instructions leave automatic updates blocked when /boot is full
1717360 test_update_origin.py test failure

Version: 1:17.04.7 2017-09-13 16:06:52 UTC
No changelog available yet.
Source diff to previous version

Version: 1:17.04.6 2017-08-29 08:07:03 UTC

  update-manager (1:17.04.6) zesty; urgency=medium

  * UpdateManager/Core/UpdateList.py: Instead of trying to print an error
    when trying to find the desktop file log it. (LP: #1428297)
  * tests/test_update_origin.py: This does not need to be architecture
    specific so just set the arch to amd64 like test_update_list.py. Replace
    references to lucid with xenial as lucid is no longer on the archive.
  * tests/test_utils.py: mock /proc/net/tcp and processes in proc so that we
    are testing the code and not the system under test.
  * tests/test_cache.py: pass an empty list when getting a changelog for 3rd
    party packages.
  * tests/test_hwe_support_status.py: port to python3.
  * tests/test_meta_release_core.py: switch to a site that works with no proxy
    in the autopkgtest environment.
  * Resolve pep8 and pyflakes issues.

 -- Brian Murray <email address hidden> Thu, 10 Aug 2017 13:58:50 -0700

Source diff to previous version

Version: 1:17.04.5 2017-08-10 16:06:49 UTC

  update-manager (1:17.04.5) zesty; urgency=medium

  * Recommend libgtk2-perl be installed so we have a working debconf frontend.
    (LP: #1607929)

 -- Brian Murray <email address hidden> Mon, 24 Jul 2017 16:43:12 -0700

Source diff to previous version
1607929 update-manager: missing dependency on libgtk2-perl for debconf frontend

Version: 1:17.04.4 2017-07-27 00:06:46 UTC

  update-manager (1:17.04.4) zesty; urgency=medium

  * update-manager: Clarify that the "-d" switch is only for upgrading from
    the latest supported release to the development release, not any release.
    (LP: #1700829)

 -- Brian Murray <email address hidden> Fri, 14 Jul 2017 16:51:54 -0700

1700829 -d switch isn't accurately described



About   -   Send Feedback to @ubuntu_updates