UbuntuUpdates.org

Package "postgresql-9.6"

Name: postgresql-9.6

Description:

object-relational SQL database, version 9.6 server

Latest version: 9.6.6-0ubuntu0.17.04
Release: zesty (17.04)
Level: updates
Repository: main
Homepage: http://www.postgresql.org/

Links

Save this URL for the latest version of "postgresql-9.6": https://www.ubuntuupdates.org/postgresql-9.6


Download "postgresql-9.6"


Other versions of "postgresql-9.6" in Zesty

Repository Area Version
base main 9.6.2-1
base universe 9.6.2-1
security main 9.6.6-0ubuntu0.17.04
security universe 9.6.6-0ubuntu0.17.04
updates universe 9.6.6-0ubuntu0.17.04
PPA: Postgresql 9.6.3-1.pgdg12.4+1
PPA: Postgresql 9.6.9-2.pgdg16.04+1
PPA: Postgresql 9.6.9-2.pgdg14.04+1
PPA: Postgresql 9.6.9-2.pgdg18.04+1

Packages in group

Deleted packages are displayed in grey.

libecpg-compat3 libecpg-dev libecpg6 libpgtypes3 libpq-dev
libpq5 postgresql-9.6-dbg postgresql-client-9.6 postgresql-contrib-9.6 postgresql-doc-9.6

Changelog

Version: 9.6.6-0ubuntu0.17.04 2017-11-14 17:06:56 UTC

  postgresql-9.6 (9.6.6-0ubuntu0.17.04) zesty-security; urgency=medium

  * New upstream release (LP: #1730661)
    - Previously, a race condition allowed some table rows to be omitted from
      the index. It may be necessary to reindex existing BRIN indexes to
      recover from past occurrences of this problem.
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.6/static/release-9-6-6.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 Nov 2017 14:33:52 +0100

Source diff to previous version
1730661 New upstream microreleases 9.3.20, 9.5.10 and 9.6.6

Version: 9.6.5-0ubuntu0.17.04 2017-09-28 18:07:11 UTC

  postgresql-9.6 (9.6.5-0ubuntu0.17.04) zesty; urgency=medium

  * New upstream release (LP: #1713979)
    - fix upgrade regressions of the former security release
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.6/static/release-9-6-5.html

 -- Christian Ehrhardt <email address hidden> Wed, 30 Aug 2017 13:01:24 +0200

Source diff to previous version
1713979 New upstream microreleases 9.3.19, 9.5.9 and 9.6.5

Version: 9.6.4-0ubuntu0.17.04.1 2017-08-15 19:06:42 UTC

  postgresql-9.6 (9.6.4-0ubuntu0.17.04.1) zesty-security; urgency=medium

  * SECURITY UPDATE: Update to 9.6.4 to fix security issues
    - Further restrict visibility of pg_user_mappings.umoptions, to protect
      passwords stored as user mapping options (CVE-2017-7547)
    - Disallow empty passwords in all password-based authentication methods
      (CVE-2017-7546)
    - Make lo_put() check for UPDATE privilege on the target large object
      (CVE-2017-7548)

 -- Marc Deslauriers <email address hidden> Mon, 14 Aug 2017 08:34:04 -0400

Source diff to previous version

Version: 9.6.3-0ubuntu0.17.04 2017-05-29 16:06:43 UTC

  postgresql-9.6 (9.6.3-0ubuntu0.17.04) zesty; urgency=medium

  * New upstream release (LP: #1690730)
    - Restrict visibility of pg_user_mappings.umoptions, to protect passwords
      stored as user mapping options (CVE-2017-7486)
    - Prevent exposure of statistical information via leaky operators
      (CVE-2017-7484)
    - Restore libpq's recognition of the PGREQUIRESSL environment variable
      (CVE-2017-7485)

    - A dump/restore is not required for those running 9.6.X.
    - However, if you use foreign data servers that make use of user passwords
      for authentication, see the first changelog entry.
    - Also, if you are using third-party replication tools that depend on
      "logical decoding", see the fourth changelog entry.

    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.6/static/release-9-6-3.html

 -- Christian Ehrhardt <email address hidden> Mon, 15 May 2017 08:46:09 +0200

1690730 New upstream microreleases 9.3.17, 9.5.7 and 9.6.3
CVE-2017-7486 PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in pg_user_mappings view which discloses foreign server passwords to any user having
CVE-2017-7484 It was found that some selectivity estimation functions in PostgreSQL before 9.2.21, 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, an
CVE-2017-7485 In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment va



About   -   Send Feedback to @ubuntu_updates