UbuntuUpdates.org

Package "webkit2gtk"

Name: webkit2gtk

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • JavaScript engine library from WebKitGTK+ - GObject introspection data
  • Web content engine library for GTK+ - GObject introspection data
  • JavaScript engine library from WebKitGTK+
  • JavaScript engine library from WebKitGTK+ - development files

Latest version: 2.18.5-0ubuntu0.17.04.1
Release: zesty (17.04)
Level: security
Repository: main

Links

Save this URL for the latest version of "webkit2gtk": https://www.ubuntuupdates.org/webkit2gtk



Other versions of "webkit2gtk" in Zesty

Repository Area Version
base universe 2.16.1-1
base main 2.16.1-1
security universe 2.18.5-0ubuntu0.17.04.1
updates main 2.18.5-0ubuntu0.17.04.1
updates universe 2.18.5-0ubuntu0.17.04.1

Packages in group

Deleted packages are displayed in grey.

gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 libjavascriptcoregtk-4.0-18 libjavascriptcoregtk-4.0-dev libwebkit2gtk-4.0-37
libwebkit2gtk-4.0-dev libwebkit2gtk-4.0-doc

Changelog

Version: 2.18.5-0ubuntu0.17.04.1 2018-01-11 20:06:56 UTC

  webkit2gtk (2.18.5-0ubuntu0.17.04.1) zesty-security; urgency=medium

  * Updated to 2.18.5 to add Spectre mitigations.
    - CVE-2017-5715, CVE-2017-5753

 -- Marc Deslauriers <email address hidden> Wed, 10 Jan 2018 11:46:16 -0500

Source diff to previous version
CVE-2017-5715 Systems with microprocessors utilizing speculative execution and indirect branch prediction may allow unauthorized disclosure of information to an at
CVE-2017-5753 Systems with microprocessors utilizing speculative execution and branch prediction may allow unauthorized disclosure of information to an attacker wi

Version: 2.18.4-0ubuntu0.17.04.1 2018-01-03 19:06:52 UTC

  webkit2gtk (2.18.4-0ubuntu0.17.04.1) zesty-security; urgency=medium

  * Updated to 2.18.4 to fix multiple security issues.
    - CVE-2017-7156, CVE-2017-13856, CVE-2017-13866, CVE-2017-13870.
  * debian/patches/*.patch: refreshed.
  * Set distributor name in User Agent string.
    - debian/patches/user-agent-branding.patch: add optional distributor
      string to user agent.
    - debian/rules: set -DUSER_AGENT_GTK_DISTRIBUTOR_NAME.

 -- Marc Deslauriers <email address hidden> Wed, 20 Dec 2017 09:25:03 -0500

Source diff to previous version
CVE-2017-7156 An issue was discovered in certain Apple products. iOS before 11.2 is affected. Safari before 11.0.2 is affected. iCloud before 7.2 on Windows is aff
CVE-2017-13856 An issue was discovered in certain Apple products. iOS before 11.2 is affected. Safari before 11.0.2 is affected. iCloud before 7.2 on Windows is aff
CVE-2017-13866 An issue was discovered in certain Apple products. iOS before 11.2 is affected. Safari before 11.0.2 is affected. iCloud before 7.2 on Windows is aff
CVE-2017-13870 An issue was discovered in certain Apple products. iOS before 11.2 is affected. Safari before 11.0.2 is affected. iCloud before 7.2 on Windows is aff

Version: 2.18.3-0ubuntu0.17.04.1 2017-11-16 14:06:17 UTC

  webkit2gtk (2.18.3-0ubuntu0.17.04.1) zesty-security; urgency=medium

  * Updated to 2.18.3 to fix multiple security issues.
    - CVE-2017-13783, CVE-2017-13784, CVE-2017-13785, CVE-2017-13788,
      CVE-2017-13791, CVE-2017-13792, CVE-2017-13793, CVE-2017-13794,
      CVE-2017-13795, CVE-2017-13796, CVE-2017-13798, CVE-2017-13802,
      CVE-2017-13803
  * debian/patches/*.patch: refreshed.

 -- Marc Deslauriers <email address hidden> Tue, 14 Nov 2017 09:08:08 -0500

Source diff to previous version
CVE-2017-13783 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13784 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13785 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13788 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13791 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13792 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13793 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13794 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13795 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13796 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13798 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13802 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff
CVE-2017-13803 An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is aff

Version: 2.18.0-0ubuntu0.17.04.2 2017-10-23 16:06:39 UTC

  webkit2gtk (2.18.0-0ubuntu0.17.04.2) zesty-security; urgency=medium

  * Updated to 2.18.0 to fix multiple security issues.
    - CVE-2017-7087, CVE-2017-7089, CVE-2017-7090, CVE-2017-7091,
      CVE-2017-7092, CVE-2017-7093, CVE-2017-7095, CVE-2017-7096,
      CVE-2017-7098, CVE-2017-7100, CVE-2017-7102, CVE-2017-7104,
      CVE-2017-7107, CVE-2017-7109, CVE-2017-7111, CVE-2017-7117,
      CVE-2017-7120
  * debian/control: add libtasn1-6-dev to BuildDepends.
  * debian/rules: use USE_GSTREAMER_GL=OFF.
  * debian/rules: don't use USE_LD_GOLD=OFF on arm64.
  * debian/rules: don't use ENABLE_ASSEMBLER=0.
  * debian/libwebkit2gtk-4.0-37.symbols: updated for new version.

 -- Marc Deslauriers <email address hidden> Thu, 19 Oct 2017 07:20:10 -0400

Source diff to previous version
CVE-2017-7087 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7089 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7090 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7091 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7092 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7093 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7095 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7096 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7098 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7100 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7102 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7104 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7107 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7109 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7111 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7117 An issue was discovered in certain Apple products. iOS before 11 is ...
CVE-2017-7120 An issue was discovered in certain Apple products. iOS before 11 is ...

Version: 2.16.6-0ubuntu0.17.04.1 2017-08-02 13:06:55 UTC

  webkit2gtk (2.16.6-0ubuntu0.17.04.1) zesty-security; urgency=medium

  * Updated to 2.16.6 to fix multiple security issues.
    - CVE-2017-2538, CVE-2017-7018, CVE-2017-7030, CVE-2017-7034,
      CVE-2017-7037, CVE-2017-7039, CVE-2017-7046, CVE-2017-7048,
      CVE-2017-7052, CVE-2017-7055, CVE-2017-7056, CVE-2017-7061,
      CVE-2017-7064

 -- Marc Deslauriers <email address hidden> Mon, 31 Jul 2017 14:51:47 -0400

CVE-2017-2538 An issue was discovered in certain Apple products. iOS before 10.3.2 is affected. Safari before 10.1.1 is affected. The issue involves the "WebKit" c
CVE-2017-7018 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7030 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7034 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7037 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7039 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7046 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7048 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7052 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7055 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7056 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7061 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is
CVE-2017-7064 An issue was discovered in certain Apple products. iOS before 10.3.3 is affected. Safari before 10.1.2 is affected. iCloud before 6.2.2 on Windows is



About   -   Send Feedback to @ubuntu_updates