UbuntuUpdates.org

Package "qemu"

Name: qemu

Description:

fast processor emulator

Latest version: 2.0.0+dfsg-2ubuntu1.43
Release: trusty (14.04)
Level: updates
Repository: universe
Homepage: http://www.qemu.org/

Links

Save this URL for the latest version of "qemu": https://www.ubuntuupdates.org/qemu


Download "qemu"


Other versions of "qemu" in Trusty

Repository Area Version
base main 2.0.0~rc1+dfsg-0ubuntu3
base universe 2.0.0~rc1+dfsg-0ubuntu3
security main 2.0.0+dfsg-2ubuntu1.43
security universe 2.0.0+dfsg-2ubuntu1.43
updates main 2.0.0+dfsg-2ubuntu1.43

Packages in group

Deleted packages are displayed in grey.

qemu-guest-agent qemu-user qemu-user-static

Changelog

Version: 2.0.0+dfsg-2ubuntu1.43 2018-06-13 18:06:51 UTC

  qemu (2.0.0+dfsg-2ubuntu1.43) trusty-security; urgency=medium

  * SECURITY UPDATE: Speculative Store Bypass
    - debian/patches/CVE-2018-3639-2.patch: define the AMD 'virt-ssbd'
      CPUID feature bit in target/i386/cpu.c.
    - debian/patches/CVE-2018-3639-3.patch: define the Virt SSBD MSR and
      handling of it in target/i386/cpu.h, target/i386/kvm.c,
      target/i386/machine.c.
    - CVE-2018-3639

 -- Marc Deslauriers <email address hidden> Wed, 23 May 2018 08:03:09 -0400

Source diff to previous version
CVE-2018-3639 Speculative Store Bypass

Version: 2.0.0+dfsg-2ubuntu1.42 2018-05-22 01:06:48 UTC

  qemu (2.0.0+dfsg-2ubuntu1.42) trusty-security; urgency=medium

  * SECURITY UPDATE: Speculative Store Bypass
    - debian/patches/ubuntu/CVE-2018-3639.patch: add bit(2) of SPEC_CTRL
      MSR support - Reduced Data Speculation to target-i386/cpu.*.
    - CVE-2018-3639

 -- Marc Deslauriers <email address hidden> Thu, 17 May 2018 10:09:16 -0400

Source diff to previous version
CVE-2018-3639 Speculative Store Bypass

Version: 2.0.0+dfsg-2ubuntu1.41 2018-05-16 17:07:25 UTC

  qemu (2.0.0+dfsg-2ubuntu1.41) trusty-security; urgency=medium

  * SECURITY UPDATE: arbitrary code execution via load_multiboot
    - debian/patches/CVE-2018-7550.patch: handle bss_end_addr being zero in
      hw/i386/multiboot.c.
    - CVE-2018-7550

 -- Marc Deslauriers <email address hidden> Fri, 11 May 2018 13:35:08 -0400

Source diff to previous version
CVE-2018-7550 The load_multiboot function in hw/i386/multiboot.c in Quick Emulator (aka QEMU) allows local guest OS users to execute arbitrary code on the QEMU hos

Version: 2.0.0+dfsg-2ubuntu1.40 2018-03-05 12:06:55 UTC

  qemu (2.0.0+dfsg-2ubuntu1.40) trusty-security; urgency=medium

  * SECURITY REGRESSION: Xen regression (LP: #1752761)
    - debian/patches/CVE-2017-11334-1.patch: removed.
    - debian/patches/CVE-2017-11334-2.patch: removed.

 -- Marc Deslauriers <email address hidden> Sun, 04 Mar 2018 10:11:19 -0500

Source diff to previous version
1752761 Regression in vga handling ubuntu10.21 to ubuntu10.22
CVE-2017-11334 The address_space_write_continue function in exec.c in QEMU (aka Quick Emulator) allows local guest OS privileged users to cause a denial of service

Version: 2.0.0+dfsg-2ubuntu1.39 2018-02-20 23:07:02 UTC

  qemu (2.0.0+dfsg-2ubuntu1.39) trusty-security; urgency=medium

  * SECURITY UPDATE: DoS via guest ram block area
    - debian/patches/CVE-2017-11334-1.patch: use qemu_ram_ptr_length to
      access guest ram in exec.c.
    - debian/patches/CVE-2017-11334-2.patch: add lock parameter to
      qemu_ram_ptr_length in exec.c.
    - CVE-2017-11334
  * SECURITY UPDATE: code execution via multiboot out-of-bounds write
    - debian/patches/CVE-2017-14167.patch: validate multiboot header
      address values in hw/i386/multiboot.c.
    - CVE-2017-14167
  * SECURITY UPDATE: information disclosure via race in 9pfs
    - debian/patches/CVE-2017-15038.patch: use g_malloc0 to allocate space
      for xattr in hw/9pfs/virtio-9p.c.
    - CVE-2017-15038
  * SECURITY UPDATE: DoS in cirrus driver
    - debian/patches/CVE-2017-15289.patch: fix oob access in mode4and5
      write functions in hw/display/cirrus_vga.c.
    - CVE-2017-15289
  * SECURITY UPDATE: DoS via integer overflow in ROUND_UP
    - debian/patches/CVE-2017-18043.patch: fix ROUND_UP in
      include/qemu/osdep.h.
    - CVE-2017-18043
  * SECURITY UPDATE: DoS in VGA driver
    - debian/patches/CVE-2018-5683.patch: check the validation of memory
      addr when draw text in hw/display/vga.c.
    - CVE-2018-5683

 -- Marc Deslauriers <email address hidden> Thu, 15 Feb 2018 13:33:14 -0500

CVE-2017-11334 The address_space_write_continue function in exec.c in QEMU (aka Quick Emulator) allows local guest OS privileged users to cause a denial of service
CVE-2017-14167 Integer overflow in the load_multiboot function in hw/i386/multiboot.c in QEMU (aka Quick Emulator) allows local guest OS users to execute arbitrary
CVE-2017-15038 Race condition in the v9fs_xattrwalk function in hw/9pfs/9p.c in QEMU (aka Quick Emulator) allows local guest OS users to obtain sensitive informatio
CVE-2017-15289 The mode4and5 write functions in hw/display/cirrus_vga.c in Qemu allow local OS guest privileged users to cause a denial of service (out-of-bounds wr
CVE-2017-18043 Integer overflow in the macro ROUND_UP (n, d) in Quick Emulator (Qemu) allows a user to cause a denial of service (Qemu process crash).
CVE-2018-5683 The vga_draw_text function in Qemu allows local OS guest privileged users to cause a denial of service (out-of-bounds read and QEMU process crash) by



About   -   Send Feedback to @ubuntu_updates