UbuntuUpdates.org

Package "rustc"

Name: rustc

Description:

Rust systems programming language

Latest version: 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1
Release: trusty (14.04)
Level: security
Repository: universe
Homepage: http://www.rust-lang.org/

Links

Save this URL for the latest version of "rustc": https://www.ubuntuupdates.org/rustc


Download "rustc"


Other versions of "rustc" in Trusty

Repository Area Version
updates universe 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1
PPA: Ubuntu Mozilla Security 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.22.1+dfsg1+llvm-0ubuntu2~14.04.2 2018-03-14 17:06:17 UTC

  rustc (1.22.1+dfsg1+llvm-0ubuntu2~14.04.2) trusty; urgency=medium

  * Backport 1.22.1 to trusty
  * Build-depend on rustc <= 1.22.1++
  * Relax the gdb requirement and don't build-conflict on gdb-minimal
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
    - update debian/rules
  * Relax dpkg-dev requirement to 1.17.5
   - update debian/control
  * Relax binutils requirement. Even though previous uploads have depended
    on a binutils-2.26, we've never actually used it
    - update debian/rules

 -- Chris Coulson <email address hidden> Tue, 05 Dec 2017 23:36:38 +0000

Source diff to previous version

Version: 1.21.0+dfsg1+llvm-0ubuntu3~14.04.5 2018-01-24 00:06:51 UTC

  rustc (1.21.0+dfsg1+llvm-0ubuntu3~14.04.5) trusty; urgency=medium

  * Backport 1.21.0 to trusty

  * Relax the gdb requirement and don't build-conflict on gdb-minimal
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
    - update debian/rules
  * Relax dpkg-dev requirement to 1.17.5
   - update debian/control
  * Relax binutils requirement. Even though previous uploads have depended
    on a binutils-2.26, we've never actually used it
    - update debian/rules
  * Set build.full-bootstrap to true to work-around a runtime link failure
    when we're bootstrapping from the same rust version
    - update debian/config.toml.in
  * Don't build with debuginfo for now, to avoid running out of address space
    on x86
    - update debian/config.toml.in

 -- Chris Coulson <email address hidden> Tue, 31 Oct 2017 20:26:19 +0000

Source diff to previous version

Version: 1.17.0+dfsg2-8~ubuntu0.14.04.3 2017-10-02 19:06:53 UTC

  rustc (1.17.0+dfsg2-8~ubuntu0.14.04.3) trusty; urgency=medium

  * Backport 1.17.0 to trusty
  * Relax llvm-toolchain-3.9 requirement to 1:3.9.1-4~
  * Relax the gdb requirement and don't build-conflict on gdb-minimal
  * Relax dpkg-dev requirement to 1.17.5
  * Don't build-Depend on nodejs on arm64, as it doesn't exist
  * Make rustc depend on binutils-2.26
  * Build-depend on libllvm3.9v4 rather than libllvm3.9

 -- Chris Coulson <email address hidden> Wed, 19 Jul 2017 18:21:28 +0100

Source diff to previous version

Version: 1.15.1+dfsg0-1~exp1ubuntu2~14.04.7 2017-06-14 20:06:42 UTC

  rustc (1.15.1+dfsg0-1~exp1ubuntu2~14.04.7) trusty-security; urgency=medium

  * Rebuild using the rustc binaries in the PPA

 -- Chris Coulson <email address hidden> Wed, 01 Mar 2017 08:48:38 +0000




About   -   Send Feedback to @ubuntu_updates