UbuntuUpdates.org

Package "systemd"

Name: systemd

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • python bindings for systemd

Latest version: 204-5ubuntu20
Release: trusty (14.04)
Level: base
Repository: universe

Links

Save this URL for the latest version of "systemd": https://www.ubuntuupdates.org/systemd



Other versions of "systemd" in Trusty

Repository Area Version
base main 204-5ubuntu20
security main 204-5ubuntu20.31
security universe 204-5ubuntu20.31
updates universe 204-5ubuntu20.31
updates main 204-5ubuntu20.31
PPA: Mint upstream 204-5ubuntu20.15linuxmint1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 204-5ubuntu20 2014-04-14 20:07:43 UTC

  systemd (204-5ubuntu20) trusty; urgency=medium

  * systemd-logind.conf: Don't use the limit stanza which fails the
    whole job when failing to set the ulimit. Instead call ulimit itself
    from the job and ignore its return code. This allow systemd-logind to
    start in unprivileged LXC containers. (LP: #1307595)
 -- Stephane Graber <email address hidden> Mon, 14 Apr 2014 12:20:33 -0400

Source diff to previous version
1307595 systemd-logind fails to start in unprivileged containers

Version: 204-5ubuntu19 2014-04-11 23:07:23 UTC

  systemd (204-5ubuntu19) trusty; urgency=medium

  * cgmanager: don't call nih_dbus_setup() since we won't use the
    nih_mainloop(). (LP: #1303649)
 -- Serge Hallyn <email address hidden> Fri, 11 Apr 2014 10:17:04 -0500

Source diff to previous version
1303649 systemd-logind spins in cgmanager_ping_sync()

Version: 204-5ubuntu18 2014-04-11 03:06:55 UTC

  systemd (204-5ubuntu18) trusty; urgency=medium

  * Revert "Do not restart logind on package upgrades" change from
    204-0ubuntu1. This is obsolete now, as we only ever shipped version 204 in
    stable releases. This was an intra-development release upgrade fix only,
    and it did not even work properly. This fixes logind not getting started
    on package install. (LP: #1305395)
  * Update 60-keyboard.hwdb from upstream git. Adds Samsung Series 7 Ultra.
  * debian/libpam-systemd.systemd-logind.upstart: Don't try to mount
    /sys/fs/cgroup/systemd in a container, as that will fail. cgmanager will
    be used for these cases.
 -- Martin Pitt <email address hidden> Thu, 10 Apr 2014 15:46:51 +0200

Source diff to previous version
1305395 systemd-login service not started on package install

Version: 204-5ubuntu17 2014-04-04 08:07:37 UTC

  systemd (204-5ubuntu17) trusty; urgency=medium

  * Fix crash on systems without cgmanager. (LP: #1302264)
 -- Stephane Graber <email address hidden> Fri, 04 Apr 2014 00:17:14 -0400

Source diff to previous version
1302264 systemd-logind assert failure: error.c:319: Assertion failed in nih_error_get: context_stack != NULL

Version: 204-5ubuntu16 2014-04-03 21:07:09 UTC

  systemd (204-5ubuntu16) trusty; urgency=medium

  [ St��phane Graber ]
  * Never call normalize_controller when controll is NULL as this
    triggers an assert... (LP: #1301846)

  [ Serge Hallyn ]
  * d/p/add-cgmanager-support: make sure connections are closed (LP: #1301882)
 -- Stephane Graber <email address hidden> Thu, 03 Apr 2014 13:53:09 -0400

1301846 loginctl crashed with SIGABRT
1301882 systemd-logind can get hung in cg_enumerate_tasks



About   -   Send Feedback to @ubuntu_updates