UbuntuUpdates.org

Package "nvidia-libopencl1-340-updates"

Name: nvidia-libopencl1-340-updates

Description:

Transitional package for nvidia-libopencl1-340

Latest version: 340.107-0ubuntu0.14.04.1
Release: trusty (14.04)
Level: updates
Repository: restricted
Head package: nvidia-graphics-drivers-340

Links

Save this URL for the latest version of "nvidia-libopencl1-340-updates": https://www.ubuntuupdates.org/nvidia-libopencl1-340-updates


Download "nvidia-libopencl1-340-updates"


Other versions of "nvidia-libopencl1-340-updates" in Trusty

Repository Area Version
security restricted 340.102-0ubuntu0.14.04.1

Changelog

Version: 340.107-0ubuntu0.14.04.1 2019-03-15 12:06:51 UTC

  nvidia-graphics-drivers-340 (340.107-0ubuntu0.14.04.1) trusty; urgency=medium

  * New upstream release:
    - Added support for X.Org xserver ABI 24 (xorg-server 1.20).
    - Improved nvidia-bug-report.sh to check for kern.log which is
      the default kernel log-file location for many Debian-based
      Linux distributions.
    - Fixed a bug which could cause X servers that export a Video
      Driver ABI earlier than 0.8 to crash when running X11
      applications which call XRenderAddTraps().
  * debian/templates/dkms_nvidia.conf.in,
    debian/dkms_nvidia/patches/buildfix_kernel_4.4_get_user_pages.patch:
   - Drop buildfix_kernel_4.9.patch and buildfix_kernel_4.10.patch.
   - Add support for new 7 argument get_user_pages() (LP: #1573508).
  * debian/substvars:
   - Add support for X ABI 24.

 -- Alberto Milone <email address hidden> Mon, 04 Mar 2019 11:18:48 +0100

Source diff to previous version
1573508 SRU Request: nvidia-*: nvidia-* kernel module failed to build [error: too many arguments to function \u2018get_user_pages\u2019]

Version: 340.102-0ubuntu0.14.04.1 2017-03-21 01:06:44 UTC

  nvidia-graphics-drivers-340 (340.102-0ubuntu0.14.04.1) trusty; urgency=medium

  * SECURITY UPDATE:
    - CVE-2017-0318 (LP: #1659586).
  * New upstream release.
  * debian/dkms_nvidia/patches/buildfix_kernel_4.9.patch,
    debian/dkms_nvidia/patches/buildfix_kernel_4.10.patch,
    debian/templates/dkms_nvidia.conf.in:
    - Add support for Linux 4.9 and 4.10.

 -- Alberto Milone <email address hidden> Mon, 06 Mar 2017 16:52:24 +0100

Source diff to previous version
CVE-2017-0318 All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parame

Version: 340.101-0ubuntu0.14.04.1 2017-01-18 02:07:04 UTC

  nvidia-graphics-drivers-340 (340.101-0ubuntu0.14.04.1) trusty; urgency=medium

  * New upstream release.
  * debian/substvars:
    - Add support for X ABI 23.

 -- Robert Hooker <email address hidden> Thu, 15 Dec 2016 11:32:22 -0500

Source diff to previous version

Version: 340.98-0ubuntu0.14.04.1 2016-11-03 18:06:36 UTC

  nvidia-graphics-drivers-340 (340.98-0ubuntu0.14.04.1) trusty-security; urgency=medium

  * SECURITY UPDATE:
    - CVE-2016-7382, 2016-7389 (LP: #1627055).
  * New upstream release:
    - Added support for the screen_info.ext_lfb_base field, on
      kernels that have it, in order to properly handle UEFI
      framebuffer consoles with physical addresses above 4GB.
  * debian/templates/control.in:
    - Add transitional packages to deprecate the -updates flavour.

 -- Alberto Milone <email address hidden> Fri, 14 Oct 2016 16:42:04 +0200

Source diff to previous version
CVE-2016-7382 RESERVED

Version: 340.96-0ubuntu0.14.04.1 2015-11-18 20:07:06 UTC

  nvidia-graphics-drivers-340 (340.96-0ubuntu0.14.04.1) trusty-security; urgency=medium

  * debian/templates/dkms_nvidia.conf.in:
    - Drop all the patches.
  * debian/substvars:
    - Add support for X ABI 20.
  * SECURITY UPDATE:
    - CVE-2015-7869 (LP: #1512414).
  * New upstream release:
    - Fixed a bug that could cause texture corruption in some OpenGL
      applications when video memory is exhausted by a combination
      of simultaneously running graphical and compute workloads.
    - Added support for X.Org xserver ABI 20 (xorg-server 1.18).

 -- Alberto Milone Fri, 13 Nov 2015 11:15:52 +0100

CVE-2015-7869 RESERVED



About   -   Send Feedback to @ubuntu_updates