UbuntuUpdates.org

Package "postgresql-9.3"

Name: postgresql-9.3

Description:

object-relational SQL database, version 9.3 server

Latest version: 9.3.21-0ubuntu0.14.04
Release: trusty (14.04)
Level: updates
Repository: main
Homepage: http://www.postgresql.org/

Links

Save this URL for the latest version of "postgresql-9.3": https://www.ubuntuupdates.org/postgresql-9.3


Download "postgresql-9.3"


Other versions of "postgresql-9.3" in Trusty

Repository Area Version
base main 9.3.4-1
security main 9.3.21-0ubuntu0.14.04
PPA: Postgresql 9.3.6-1.pgdg10.4+1
PPA: Postgresql 9.3.17-1.pgdg12.4+1
PPA: Postgresql 9.3.21-1.pgdg16.04+1
PPA: Postgresql 9.3.21-1.pgdg14.04+1

Packages in group

Deleted packages are displayed in grey.

libecpg-compat3 libecpg-dev libecpg6 libpgtypes3 libpq-dev
libpq5 postgresql-9.3-dbg postgresql-client-9.3 postgresql-contrib-9.3 postgresql-doc-9.3
postgresql-plperl-9.3 postgresql-plpython-9.3 postgresql-plpython3-9.3 postgresql-pltcl-9.3 postgresql-server-dev-9.3

Changelog

Version: 9.3.21-0ubuntu0.14.04 2018-02-09 15:06:37 UTC

  postgresql-9.3 (9.3.21-0ubuntu0.14.04) trusty-security; urgency=medium

  * New upstream release (LP: #1747676)
    - Ensure that all temporary files made by pg_upgrade are non-world-readable
      (CVE-2018-1053)
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.3/static/release-9-3-21.html

 -- Christian Ehrhardt <email address hidden> Tue, 06 Feb 2018 15:19:51 +0100

Source diff to previous version
1747676 New upstream microreleases 9.3.21, 9.5.11 and 9.6.7
CVE-2018-1053 Ensure that all temp files made during pg_upgrade are non-world-readable

Version: 9.3.20-0ubuntu0.14.04 2017-11-14 17:06:52 UTC

  postgresql-9.3 (9.3.20-0ubuntu0.14.04) trusty-security; urgency=medium

  * New upstream release (LP: #1730661)
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.3/static/release-9-3-20.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 Nov 2017 14:33:47 +0100

Source diff to previous version
1730661 New upstream microreleases 9.3.20, 9.5.10 and 9.6.6

Version: 9.3.19-0ubuntu0.14.04 2017-09-28 19:07:06 UTC

  postgresql-9.3 (9.3.19-0ubuntu0.14.04) trusty; urgency=medium

  * New upstream release (LP: #1713979)
    - fix upgrade regressions of the former security release
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.3/static/release-9-3-19.html

 -- Christian Ehrhardt <email address hidden> Wed, 30 Aug 2017 13:00:40 +0200

Source diff to previous version
1713979 New upstream microreleases 9.3.19, 9.5.9 and 9.6.5

Version: 9.3.18-0ubuntu0.14.04.1 2017-08-15 19:06:35 UTC

  postgresql-9.3 (9.3.18-0ubuntu0.14.04.1) trusty-security; urgency=medium

  * SECURITY UPDATE: Update to 9.3.18 to fix security issues
    - Further restrict visibility of pg_user_mappings.umoptions, to protect
      passwords stored as user mapping options (CVE-2017-7547)
    - Disallow empty passwords in all password-based authentication methods
      (CVE-2017-7546)
    - Make lo_put() check for UPDATE privilege on the target large object
      (CVE-2017-7548)

 -- Marc Deslauriers <email address hidden> Mon, 14 Aug 2017 10:28:33 -0400

Source diff to previous version

Version: 9.3.17-0ubuntu0.14.04 2017-06-01 16:06:42 UTC

  postgresql-9.3 (9.3.17-0ubuntu0.14.04) trusty; urgency=medium

  * New upstream release (LP: #1690730)
    - Restrict visibility of pg_user_mappings.umoptions, to protect passwords
      stored as user mapping options (CVE-2017-7486)
    - Prevent exposure of statistical information via leaky operators
      (CVE-2017-7484)
    - Restore libpq's recognition of the PGREQUIRESSL environment variable
      (CVE-2017-7485)

    - A dump/restore is not required for those running 9.3.X.
    - However, if you use foreign data servers that make use of user passwords
      for authentication, see the first changelog entry.

    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.3/static/release-9-3-17.html

 -- Christian Ehrhardt <email address hidden> Mon, 15 May 2017 08:45:01 +0200

1690730 New upstream microreleases 9.3.17, 9.5.7 and 9.6.3
CVE-2017-7486 PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in pg_user_mappings view which discloses foreign server passwords to any user having
CVE-2017-7484 It was found that some selectivity estimation functions in PostgreSQL before 9.2.21, 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, an
CVE-2017-7485 In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment va



About   -   Send Feedback to @ubuntu_updates