Package "libecpg-compat3"

Name: libecpg-compat3


older version of run-time library for ECPG programs

Latest version: 9.3.24-0ubuntu0.14.04
Release: trusty (14.04)
Level: updates
Repository: main
Head package: postgresql-9.3
Homepage: http://www.postgresql.org/


Download "libecpg-compat3"

Other versions of "libecpg-compat3" in Trusty

Repository Area Version
base main 9.3.4-1
security main 9.3.24-0ubuntu0.14.04
PPA: Postgresql 9.4.1-1.pgdg10.4+1
PPA: Postgresql 9.6.3-1.pgdg12.4+1
PPA: Postgresql 11.3-1.pgdg14.04+1
PPA: Postgresql 13.3-1.pgdg16.04+1
PPA: Postgresql 15.2-1.pgdg20.04+1
PPA: Postgresql 15.2-1.pgdg22.04+1
PPA: Postgresql 15.2-1.pgdg18.04+1


Version: 9.3.24-0ubuntu0.14.04 2018-08-17 02:33:25 UTC

  postgresql-9.3 (9.3.24-0ubuntu0.14.04) trusty-security; urgency=medium

  * New upstream release (LP: #1786938)
    - Fix failure to reset libpq's state fully between connection attempts
      An unprivileged user of dblink or postgres_fdw could bypass the checks
      intended to prevent use of server-side credentials, such as a ~/.pgpass
      file owned by the operating-system user running the server. Servers
      allowing peer authentication on local connections are particularly
      vulnerable. Other attacks such as SQL injection into a postgres_fdw
      session are also possible. Attacking postgres_fdw in this way requires
      the ability to create a foreign server object with selected connection
      parameters, but any user with access to dblink could exploit the
      problem. In general, an attacker with the ability to select the
      connection parameters for a libpq-using application could cause
      mischief, though other plausible attack scenarios are harder to think
      of. Our thanks to Andrew Krasichkov for reporting this issue.
    - d/libecpg-dev.install: Add new pgtypes header.
    - d/libpgtypes3.symbols: Add new pgtypes symbol.
    - Details about these and other changes can be found at

 -- Christian Ehrhardt <email address hidden> Tue, 14 Aug 2018 14:49:12 +0200

Source diff to previous version
1786938 New upstream microreleases 9.3.24, 9.5.14, and 10.5
CVE-2018-10915 A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections

Version: 9.3.23-0ubuntu0.14.04 2018-06-04 09:07:13 UTC

  postgresql-9.3 (9.3.23-0ubuntu0.14.04) trusty; urgency=medium

  * New upstream release (LP: #1769888)
    - A dump/restore is not required for those running 9.3.X.
      However, if the function marking mistakes mentioned in the first
      changelog entry affect you, you will want to take steps to
      correct your database catalogs.
    - Details about changes can be found at

 -- Christian Ehrhardt <email address hidden> Tue, 08 May 2018 15:17:51 +0200

Source diff to previous version
1769888 New upstream microreleases 9.3.23, 9.5.13, 9.6.9 and 10.4

Version: 9.3.22-0ubuntu0.14.04 2018-03-06 11:07:41 UTC

  postgresql-9.3 (9.3.22-0ubuntu0.14.04) trusty-security; urgency=medium

  * New upstream release (LP: #1752271)
    If you run an installation in which not all users are mutually
    trusting, or if you maintain an application or extension that is
    intended for use in arbitrary situations, it is strongly recommended
    that you read the documentation changes described in the first changelog
    entry below, and take suitable steps to ensure that your installation or
    code is secure.

    Also, the changes described in the second changelog entry below may
    cause functions used in index expressions or materialized views to fail
    during auto-analyze, or when reloading from a dump. After upgrading,
    monitor the server logs for such problems, and fix affected functions.

    - Document how to configure installations and applications to guard
      against search-path-dependent trojan-horse attacks from other users

      Using a search_path setting that includes any schemas writable by a
      hostile user enables that user to capture control of queries and then
      run arbitrary SQL code with the permissions of the attacked user. While
      it is possible to write queries that are proof against such hijacking,
      it is notationally tedious, and it's very easy to overlook holes.
      Therefore, we now recommend configurations in which no untrusted schemas
      appear in one's search path.

    - Avoid use of insecure search_path settings in pg_dump and other client

      pg_dump, pg_upgrade, vacuumdb and other PostgreSQL-provided applications
      were themselves vulnerable to the type of hijacking described in the
      previous changelog entry; since these applications are commonly run by
      superusers, they present particularly attractive targets. To make them
      secure whether or not the installation as a whole has been secured,
      modify them to include only the pg_catalog schema in their search_path
      settings. Autovacuum worker processes now do the same, as well.

      In cases where user-provided functions are indirectly executed by these
      programs -- for example, user-provided functions in index expressions --
      the tighter search_path may result in errors, which will need to be
      corrected by adjusting those user-provided functions to not assume
      anything about what search path they are invoked under. That has always
      been good practice, but now it will be necessary for correct behavior.

    - Details about other changes can be found at

 -- Christian Ehrhardt <email address hidden> Wed, 28 Feb 2018 09:59:05 +0100

Source diff to previous version
1752271 New upstream microreleases 9.3.22, 9.5.12, 9.6.8 and 10.3
CVE-2018-1058 A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other users. An attacker with a user account could use th

Version: 9.3.21-0ubuntu0.14.04 2018-02-09 15:06:37 UTC

  postgresql-9.3 (9.3.21-0ubuntu0.14.04) trusty-security; urgency=medium

  * New upstream release (LP: #1747676)
    - Ensure that all temporary files made by pg_upgrade are non-world-readable
    - Details about other changes at full changelog:

 -- Christian Ehrhardt <email address hidden> Tue, 06 Feb 2018 15:19:51 +0100

Source diff to previous version
1747676 New upstream microreleases 9.3.21, 9.5.11 and 9.6.7
CVE-2018-1053 Ensure that all temp files made during pg_upgrade are non-world-readable

Version: 9.3.20-0ubuntu0.14.04 2017-11-14 17:06:52 UTC

  postgresql-9.3 (9.3.20-0ubuntu0.14.04) trusty-security; urgency=medium

  * New upstream release (LP: #1730661)
    - Details about other changes at full changelog:

 -- Christian Ehrhardt <email address hidden> Tue, 07 Nov 2017 14:33:47 +0100

1730661 New upstream microreleases 9.3.20, 9.5.10 and 9.6.6

About   -   Send Feedback to @ubuntu_updates