UbuntuUpdates.org

Package "libsystemd-daemon0"

Name: libsystemd-daemon0

Description:

systemd utility library

Latest version: 204-5ubuntu20.31
Release: trusty (14.04)
Level: security
Repository: main
Head package: systemd
Homepage: http://www.freedesktop.org/wiki/Software/systemd

Links

Save this URL for the latest version of "libsystemd-daemon0": https://www.ubuntuupdates.org/libsystemd-daemon0


Download "libsystemd-daemon0"


Other versions of "libsystemd-daemon0" in Trusty

Repository Area Version
base main 204-5ubuntu20
updates main 204-5ubuntu20.31
PPA: Mint upstream 204-5ubuntu20.15linuxmint1

Changelog

Version: 204-5ubuntu20.31 2019-04-08 12:07:03 UTC

  systemd (204-5ubuntu20.31) trusty-security; urgency=medium

  * SECURITY UDPATE: Unsafe environment usage in pam_systemd.so leads to
    incorrect Policykit authorization
    - debian/patches/CVE-2019-3842.patch: Use secure_getenv() rather than
      getenv() in pam_systemd.c
    - CVE-2019-3842

 -- Chris Coulson <email address hidden> Thu, 07 Mar 2019 16:30:13 +0000

Source diff to previous version
CVE-2019-3842 RESERVED

Version: 204-5ubuntu20.26 2018-02-05 20:06:25 UTC

  systemd (204-5ubuntu20.26) trusty-security; urgency=medium

  * SECURITY UPDATE: access to automounted volumes can lock up
    (LP: #1709649)
    - debian/patches/CVE-2018-1049.patch: ack automount requests even when
      already mounted in src/core/automount.c.
    - CVE-2018-1049

 -- Marc Deslauriers <email address hidden> Thu, 01 Feb 2018 07:52:32 -0500

1709649 229 backport for race between explicit mount and handling automount
CVE-2018-1049 automount: access to automounted volumes can lock up



About   -   Send Feedback to @ubuntu_updates