UbuntuUpdates.org

Package "libffi"

Name: libffi

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Foreign Function Interface library (development files)
  • Foreign Function Interface library runtime
  • Foreign Function Interface library runtime (debug symbols)

Latest version: 3.1~rc1+r3.0.13-12ubuntu0.2
Release: trusty (14.04)
Level: security
Repository: main

Links

Save this URL for the latest version of "libffi": https://www.ubuntuupdates.org/libffi



Other versions of "libffi" in Trusty

Repository Area Version
base main 3.1~rc1+r3.0.13-12
updates main 3.1~rc1+r3.0.13-12ubuntu0.2

Packages in group

Deleted packages are displayed in grey.

libffi-dev libffi6 libffi6-dbg

Changelog

Version: 3.1~rc1+r3.0.13-12ubuntu0.2 2017-10-12 20:06:47 UTC

  libffi (3.1~rc1+r3.0.13-12ubuntu0.2) trusty-security; urgency=medium

  * SECURITY UPDATE: executable stack
    - debian/patches/CVE-2017-1000376.patch: add missing GNU stack markings
      in src/x86/win32.S.
    - debian/patches/pax_status.patch: check /proc/self/status for PaX
      status in src/closures.c.
    - debian/rules: build with --enable-pax_emutramp.
    - CVE-2017-1000376

 -- Marc Deslauriers <email address hidden> Tue, 27 Jun 2017 07:52:51 -0400

CVE-2017-1000 RESERVED



About   -   Send Feedback to @ubuntu_updates