UbuntuUpdates.org

Package "apt"

Name: apt

Description:

commandline package manager

Latest version: 1.0.1ubuntu2.19
Release: trusty (14.04)
Level: security
Repository: main

Links

Save this URL for the latest version of "apt": https://www.ubuntuupdates.org/apt


Download "apt"


Other versions of "apt" in Trusty

Repository Area Version
base main 1.0.1ubuntu2
updates main 1.0.1ubuntu2.23

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.0.1ubuntu2.19 2019-01-22 13:06:55 UTC

  apt (1.0.1ubuntu2.19) trusty-security; urgency=medium

  * SECURITY UPDATE: content injection in http method (CVE-2019-3462)
    (LP: #1812353)

 -- Julian Andres Klode <email address hidden> Fri, 18 Jan 2019 16:35:08 +0100

Source diff to previous version
1812353 content injection in http method (CVE-2019-3462)
CVE-2019-3462 Content injection in APT http medhod when using redirects

Version: 1.0.1ubuntu2.17 2016-12-13 19:07:00 UTC

  apt (1.0.1ubuntu2.17) trusty-security; urgency=high

  * SECURITY UPDATE: gpgv: Check for errors when splitting files (CVE-2016-1252)
    Thanks to Jann Horn, Google Project Zero for reporting the issue
    (LP: #1647467)

 -- Julian Andres Klode <email address hidden> Thu, 08 Dec 2016 15:31:29 +0100

Source diff to previous version
1647467 InRelease file splitter treats getline() errors as EOF

Version: 1.0.1ubuntu2.13 2016-04-27 01:06:25 UTC

  apt (1.0.1ubuntu2.13) trusty; urgency=medium

  * Recheck Pre-Depends satisfaction in SmartConfigure, to avoid unconfigured
    Pre-Depends (which dpkg later fails on). Fixes upgrade failures of
    systemd, util-linux, and other packages with Pre-Depends. Many thanks to
    David Kalnischkies for figuring out the patch and Winfried PLappert for
    testing! Patch taken from Debian git. (LP: #1560797)

 -- Martin Pitt <email address hidden> Tue, 19 Apr 2016 12:32:43 +0200

Source diff to previous version
1560797 package systemd-sysv 225-1ubuntu9.1 failed to install/upgrade: libgcrypt20 was unconfigured during 15.10 to 16.04 upgrade

Version: 1.0.1ubuntu2.5 2014-10-08 15:06:35 UTC

  apt (1.0.1ubuntu2.5) trusty-security; urgency=low

  * SECURITY UPDATE:
      - cmdline/apt-get.cc: fix insecure tempfile handling in
        apt-get changelog (CVE-2014-7206). Thanks to Guillem Jover
 -- Michael Vogt <email address hidden> Wed, 08 Oct 2014 10:38:50 +0200

Source diff to previous version
CVE-2014-7206 apt-get: Insecure temporary changelog handling

Version: 1.0.1ubuntu2.4.1 2014-09-23 17:07:23 UTC

  apt (1.0.1ubuntu2.4.1) trusty-security; urgency=low

  * SECURITY UPDATE:
    - fix potential buffer overflow, thanks to the
      Google Security Team (CVE-2014-6273)
  * Fix regression from the previous upload when file:/// sources
    are used and those are on a different partition than
    the apt state directory
  * Fix regression when Dir::state::lists is set to a relative path
  * Fix regression when cdrom: sources got rewriten by apt-cdrom add
 -- Michael Vogt <email address hidden> Tue, 23 Sep 2014 09:04:44 +0200

CVE-2014-6273 buffer overflow in the HTTP transport code in apt-get



About   -   Send Feedback to @ubuntu_updates