UbuntuUpdates.org

Package "libseccomp"




Name: libseccomp

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • high level interface to Linux seccomp filter (development files)
  • high level interface to Linux seccomp filter

Latest version: *DELETED*
Release: trusty (14.04)
Level: proposed
Repository: main

Links

Save this URL for the latest version of "libseccomp": https://www.ubuntuupdates.org/libseccomp



Other versions of "libseccomp" in Trusty

Repository Area Version
base universe 2.1.0+dfsg-1
security universe 2.1.1-1ubuntu1~trusty5
security main 2.1.1-1ubuntu1~trusty5
updates universe 2.1.1-1ubuntu1~trusty5
updates main 2.1.1-1ubuntu1~trusty5
backports main 2.2.3-2ubuntu1~ubuntu14.04.1
backports universe 2.2.3-2ubuntu1~ubuntu14.04.1
PPA: Ubuntu SDK Release 2.3.1-2ubuntu2~ubuntu14.04.1~ppa1
PPA: Lxd 2.3.1-2.1ubuntu3~ubuntu14.04.1~ppa1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2019-05-31 00:06:46 UTC
No changelog for deleted or moved packages.

Version: 2.4.1-0ubuntu0.14.04.2 2019-05-21 17:06:56 UTC

  libseccomp (2.4.1-0ubuntu0.14.04.2) trusty-security; urgency=medium

  [ Marc Deslauriers ]
  * Updated to new upstream 2.4.1 version to fix security issue.
    - CVE-2019-9893
  * debian/patches/*: removed, all included in new version.
  * debian/control: add valgrind to Build-Depends to get more unit tests.
  * debian/libseccomp2.symbols: updated symbols.
  * debian/rules: fix override_dh_auto_clean.
  * debian/docs: removed, new version doesn't have README file.

  [ Jamie Strandboge ]
  * db-properly-reset-attribute-state.patch: db: properly reset the attribute
    state in db_col_reset()

 -- Jamie Strandboge <email address hidden> Fri, 03 May 2019 20:12:07 +0000

CVE-2019-9893 libseccomp before 2.4.0 did not correctly generate 64-bit syscall argument comparisons using the arithmetic operators (LT, GT, LE, GE), which might a

Version: *DELETED* 2017-08-15 17:06:40 UTC
No changelog for deleted or moved packages.

Version: 2.1.1-1ubuntu1~trusty4 2017-07-11 14:07:10 UTC

  libseccomp (2.1.1-1ubuntu1~trusty4) trusty-proposed; urgency=medium

  * debian/libseccomp-dev.install: include static library
    (LP: #1703580)

 -- Michael Vogt <email address hidden> Tue, 11 Jul 2017 12:22:18 +0200

1703580 Include static library

Version: *DELETED* 2017-01-19 02:06:39 UTC
No changelog for deleted or moved packages.



About   -   Send Feedback to @ubuntu_updates