UbuntuUpdates.org

Package "apt"

Name: apt

Description:

commandline package manager

Latest version: 1.0.1ubuntu2
Release: trusty (14.04)
Level: base
Repository: main

Links

Save this URL for the latest version of "apt": https://www.ubuntuupdates.org/apt


Download "apt"


Other versions of "apt" in Trusty

Repository Area Version
security main 1.0.1ubuntu2.19
updates main 1.0.1ubuntu2.23

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.0.1ubuntu2 2014-04-10 15:07:06 UTC

  apt (1.0.1ubuntu2) trusty; urgency=low

  * fix symlink of etc/apt/apt.conf.d/01autoremove when runnning in
    the auto-pkg-test environment
 -- Michael Vogt <email address hidden> Thu, 10 Apr 2014 14:24:25 +0200

Source diff to previous version

Version: 0.9.15.4ubuntu5 2014-04-07 12:06:57 UTC

  apt (0.9.15.4ubuntu5) trusty; urgency=low

  [ Julian Andres Klode ]
  * Version the Breaks/Replaces for sun-java{5,6}-jdk
    (LP: #1302736)
  * Add versioned openjdk-6-jdk breaks
 -- Michael Vogt <email address hidden> Mon, 07 Apr 2014 11:40:40 +0200

Source diff to previous version
1302736 apt 0.9.15.4ubuntu4 uninstalls ppa:webupd8team/java oracle-java[78]-installer

Version: 0.9.15.4ubuntu4 2014-04-04 12:07:11 UTC

  apt (0.9.15.4ubuntu4) trusty; urgency=low

  Cherry pick fixes from the apt 1.0 branch:

  [ Michael Vogt ]
  * add sun-java{5,6}-jdk to breaks/replaces as that provided a "apt"
    binary as well

  [ David Kalnischkies ]
  * ensure proper teardown in dpkg error cases (Closes: 738969)
  * use the pretty fullname of a pkg as download desciption
  * cmdline parsing: apt-config is not apt-cdrom
  * do not configure already unpacked packages needlessly (Closes: 740843)
    LP: #1286161

  [ Julian Andres Klode ]
  * Promote xz-utils from apt Suggests to libapt-pkg Depends
 -- Michael Vogt <email address hidden> Fri, 04 Apr 2014 09:08:51 +0200

Source diff to previous version
1286161 13.10 -\u003e 14.04 upgrade failed: initramfs failed to ugprade, udev is not configured yet

Version: 0.9.15.4ubuntu3 2014-04-02 17:07:12 UTC

  apt (0.9.15.4ubuntu3) trusty; urgency=low

  * cherry pick git commit b68ce88357daf36 to fix crash in
    apt-extracttemplates (LP: #1288718)
 -- Michael Vogt <email address hidden> Wed, 02 Apr 2014 15:00:11 +0200

Source diff to previous version
1288718 apt-extracttemplates crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()

Version: 0.9.15.4ubuntu2 2014-02-27 20:07:34 UTC

  apt (0.9.15.4ubuntu2) trusty; urgency=medium

  * debian/tests/control: Add missing build-essential, fakeroot, and wget test
    dependencies.
  * debian/tests/run-tests: Pin locale to C to avoid test failures in other
    locales.
 -- Martin Pitt <email address hidden> Mon, 24 Feb 2014 18:26:13 +0100




About   -   Send Feedback to @ubuntu_updates