UbuntuUpdates.org

Package "chromium-browser"

Name: chromium-browser

Description:

Chromium browser

Latest version: 18.0.1025.151~r130497-0ubuntu1
Release: precise (12.04)
Level: base
Repository: universe
Homepage: http://code.google.com/chromium/

Links


Download "chromium-browser"


Other versions of "chromium-browser" in Precise

Repository Area Version
security universe 37.0.2062.120-0ubuntu0.12.04.4
updates universe 37.0.2062.120-0ubuntu0.12.04.4
PPA: Chromium Stable Channel 30.0.1599.114-0ubuntu0.12.04.4~cm0precise
PPA: WebApps Preview 20.0.1132.47~r144678-0precise1+webapps7
PPA: Mint Upstream 2020.10.27
PPA: Mint Upstream 2020.10.27

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 17.0.963.66~r124982-0ubuntu1 2012-03-07 12:04:54 UTC

chromium-browser (17.0.963.66~r124982-0ubuntu1) precise; urgency=low

  * New upstream release from the Stable Channel (LP: #948749)
    - fixes regression in the DOM [116789]

  [ Micah Gersten ]
  * Revert manual changes to v8 build system since we're using the gyp flag now
    - update debian/patches/fix-armhf-ftbfs.patch

  [ Jani Monoses ]
  * Attempt to fix armhf build again (LP: #943281)
    - update debian/rules

 -- Micah Gersten Wed, 07 Mar 2012 02:00:53 -0600


Version: *DELETED* 2012-03-06 10:08:27 UTC
No changelog for deleted or moved packages.

Version: 17.0.963.65~r124586-0ubuntu1 2012-03-05 14:04:50 UTC

chromium-browser (17.0.963.65~r124586-0ubuntu1) precise; urgency=low

  * New upstream release from the Stable Channel (LP: #946914)
    - Cursors and backgrounds sometimes do not load [111218]
    - Plugins not loading on some pages [108228]
    - Text paste includes trailing spaces [106551]
    - Websites using touch controls break [110332]
    This release fixes the following security issues:
    - [105867] High CVE-2011-3031: Use-after-free in v8 element wrapper. Credit
      to Chamal de Silva.
    - [108037] High CVE-2011-3032: Use-after-free in SVG value handling. Credit
      to Arthur Gerkis.
    - [108406] [115471] High CVE-2011-3033: Buffer overflow in the Skia drawing
      library. Credit to Aki Helin of OUSPG.
    - [111748] High CVE-2011-3034: Use-after-free in SVG document handling.
      Credit to Arthur Gerkis.
    - [112212] High CVE-2011-3035: Use-after-free in SVG use handling. Credit to
      Arthur Gerkis.
    - [113258] High CVE-2011-3036: Bad cast in line box handling. Credit to
      miaubiz.
    - [113439] [114924] [115028] High CVE-2011-3037: Bad casts in anonymous
      block splitting. Credit to miaubiz.
    - [113497] High CVE-2011-3038: Use-after-free in multi-column handling.
      Credit to miaubiz.
    - [113707] High CVE-2011-3039: Use-after-free in quote handling. Credit to
      miaubiz.
    - [114054] High CVE-2011-3040: Out-of-bounds read in text handling. Credit
      to miaubiz.
    - [114068] High CVE-2011-3041: Use-after-free in class attribute handling.
      Credit to miaubiz.
    - [114219] High CVE-2011-3042: Use-after-free in table section handling.
      Credit to miaubiz.
    - [115681] High CVE-2011-3043: Use-after-free in flexbox with floats. Credit
      to miaubiz.
    - [116093] High CVE-2011-3044: Use-after-free with SVG animation elements.
      Credit to Arthur Gerkis.

  [ Jani Monoses ]
  * Fix FTBFS on armhf (LP: #943281)
    - add debian/patches/fix-armhf-ftbfs.patch
    - update debian/patches/series

 -- Micah Gersten Mon, 05 Mar 2012 03:48:05 -0600

Source diff to previous version
CVE-2011-3031 RESERVED
CVE-2011-3032 RESERVED
CVE-2011-3033 RESERVED
CVE-2011-3034 RESERVED
CVE-2011-3035 RESERVED
CVE-2011-3036 RESERVED
CVE-2011-3037 RESERVED
CVE-2011-3038 RESERVED
CVE-2011-3039 RESERVED
CVE-2011-3040 RESERVED
CVE-2011-3041 RESERVED
CVE-2011-3042 RESERVED
CVE-2011-3043 RESERVED
CVE-2011-3044 RESERVED

Version: 17.0.963.56~r121963-0ubuntu3 2012-02-20 11:04:05 UTC

chromium-browser (17.0.963.56~r121963-0ubuntu3) precise; urgency=low

  * Fix arm specific flags again; Use findstring instead of filter as arm
    isn't the entire build arch name
    - update debian/rules

 -- Micah Gersten Mon, 20 Feb 2012 00:59:09 -0600

Source diff to previous version

Version: 17.0.963.56~r121963-0ubuntu1 2012-02-16 09:03:22 UTC

chromium-browser (17.0.963.56~r121963-0ubuntu1) precise; urgency=low

  * New upstream release from the Stable Channel (LP: #933262)
    This release fixes the following security issues:
    - [105803] High CVE-2011-3015: Integer overflows in PDF codecs. Credit to
      Google Chrome Security Team (scarybeasts).
    - [106336] Medium CVE-2011-3016: Read-after-free with counter nodes. Credit
      to miaubiz.
    - [108695] High CVE-2011-3017: Possible use-after-free in database handling.
      Credit to miaubiz.
    - [110172] High CVE-2011-3018: Heap overflow in path rendering. Credit to
      Aki Helin of OUSPG.
    - [110849] High CVE-2011-3019: Heap buffer overflow in MKV handling. Credit
      to Google Chrome Security Team (scarybeasts) and Mateusz Jurczyk of the
      Google Security Team.
    - [111575] Medium CVE-2011-3020: Native client validator error. Credit to
      Nick Bray of the Chromium development community.
    - [111779] High CVE-2011-3021: Use-after-free in subframe loading. Credit to
      Arthur Gerkis.
    - [112236] Medium CVE-2011-3022: Inappropriate use of http for translation
      script. Credit to Google Chrome Security Team (Jorge Obes).
    - [112259] Medium CVE-2011-3023: Use-after-free with drag and drop. Credit
      to pa_kt.
    - [112451] Low CVE-2011-3024: Browser crash with empty x509 certificate.
      Credit to chrometot.
    - [112670] Medium CVE-2011-3025: Out-of-bounds read in h.264 parsing. Credit
      to Sławomir Błażek.
    - [112822] High CVE-2011-3026: Integer overflow / truncation in libpng.
      Credit to Jüri Aedla.
    - [112847] High CVE-2011-3027: Bad cast in column handling. Credit to
      miaubiz.

 -- Micah Gersten Wed, 15 Feb 2012 22:55:08 -0600

933262 Update to 17.0.963.56
CVE-2011-3015 RESERVED
CVE-2011-3016 RESERVED
CVE-2011-3017 RESERVED
CVE-2011-3018 RESERVED
CVE-2011-3019 RESERVED
CVE-2011-3020 RESERVED
CVE-2011-3021 RESERVED
CVE-2011-3022 RESERVED
CVE-2011-3023 RESERVED
CVE-2011-3024 RESERVED
CVE-2011-3025 RESERVED
CVE-2011-3027 RESERVED



About   -   Send Feedback to @ubuntu_updates