UbuntuUpdates.org

Package "cups"

Name: cups

Description:

Common UNIX Printing System(tm) - PPD/driver support, web interface

Latest version: 2.4.6-0ubuntu3.2
Release: mantic (23.10)
Level: security
Repository: main
Homepage: https://github.com/OpenPrinting/cups/

Links


Download "cups"


Other versions of "cups" in Mantic

Repository Area Version
base main 2.4.6-0ubuntu3
updates main 2.4.6-0ubuntu3.2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.4.6-0ubuntu3.2 2024-06-28 13:07:13 UTC

  cups (2.4.6-0ubuntu3.2) mantic-security; urgency=medium

  * SECURITY REGRESSION: early exit on missing listen directive
    - d/p/fix-scheduler-start-if-only-domain-socket-to-listen.patch: don't
      exit if no valid Listen or Port found (LP: #2070315)

 -- Sudhakar Verma <email address hidden> Thu, 27 Jun 2024 19:13:38 +0530

Source diff to previous version
2070315 error in /etc/cups/cupsd.conf from today's patch

Version: 2.4.6-0ubuntu3.1 2024-06-24 13:07:40 UTC

  cups (2.4.6-0ubuntu3.1) mantic-security; urgency=medium

   * SECURITY UPDATE: cupsd listen arbitrary chmod 0140777
    - debian/patches/CVE-2024-35235.patch: validate status of unlink and bind
      in cups/http-addr.c
    - CVE-2024-35235

 -- Sudhakar Verma <email address hidden> Fri, 21 Jun 2024 15:41:01 +0530

CVE-2024-35235 OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.8 and earlier, when starting the



About   -   Send Feedback to @ubuntu_updates