UbuntuUpdates.org

Package "libjavascriptcoregtk-4.0-bin"

Name: libjavascriptcoregtk-4.0-bin

Description:

JavaScript engine library from WebKitGTK - command-line interpreter

Latest version: 2.36.8-0ubuntu0.22.04.1
Release: jammy (22.04)
Level: security
Repository: universe
Head package: webkit2gtk
Homepage: https://webkitgtk.org/

Links


Download "libjavascriptcoregtk-4.0-bin"


Other versions of "libjavascriptcoregtk-4.0-bin" in Jammy

Repository Area Version
base universe 2.36.0-2ubuntu1
updates universe 2.36.8-0ubuntu0.22.04.1

Changelog

Version: 2.36.8-0ubuntu0.22.04.1 2022-09-26 17:06:23 UTC

  webkit2gtk (2.36.8-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Updated to 2.36.8 to fix security issues.
    - CVE-2022-32886

 -- Marc Deslauriers <email address hidden> Wed, 21 Sep 2022 10:10:41 -0400

Source diff to previous version
CVE-2022-32886 A buffer overflow issue was addressed with improved memory handling. This issue is fixed in Safari 16, iOS 16, iOS 15.7 and iPadOS 15.7. Processing m

Version: 2.36.7-0ubuntu0.22.04.1 2022-09-15 12:07:06 UTC

  webkit2gtk (2.36.7-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Updated to 2.36.7 to fix security issues.
    - CVE-2022-32893

 -- Marc Deslauriers <email address hidden> Mon, 12 Sep 2022 09:46:43 -0400

Source diff to previous version
CVE-2022-32893 An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.6.1 and iPadOS 15.6.1, macOS Monterey 12.5.1,

Version: 2.36.6-0ubuntu0.22.04.1 2022-08-15 13:07:07 UTC

  webkit2gtk (2.36.6-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Updated to 2.36.6 to fix security issues.
    - CVE-2022-32792, CVE-2022-32816, CVE-2022-2294

 -- Marc Deslauriers <email address hidden> Thu, 11 Aug 2022 08:15:20 -0400

Source diff to previous version
CVE-2022-32792 An out-of-bounds write issue was addressed with improved input validation
CVE-2022-32816 A UI spoofing issue was addressed with improved UI handling
CVE-2022-2294 Heap buffer overflow in WebRTC in Google Chrome prior to 103.0.5060.114 allowed a remote attacker to potentially exploit heap corruption via a crafte

Version: 2.36.4-0ubuntu0.22.04.1 2022-07-18 16:06:29 UTC

  webkit2gtk (2.36.4-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Updated to 2.36.4 to fix security issues.
    - CVE-2022-22662 (fixed in 2.36.0).
    - CVE-2022-22677 and CVE-2022-26710 (fixed in 2.36.4).

 -- Spyros Seimenis <email address hidden> Wed, 13 Jul 2022 18:37:27 +0300

Source diff to previous version
CVE-2022-22662 A cookie management issue was addressed with improved state management. This issue is fixed in Security Update 2022-003 Catalina, macOS Big Sur 11.6.

Version: 2.36.3-0ubuntu0.22.04.1 2022-06-01 12:06:22 UTC

  webkit2gtk (2.36.3-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Updated to 2.36.3 to fix security issues.
    - CVE-2022-26700, CVE-2022-26709, CVE-2022-26716, CVE-2022-26717,
      CVE-2022-26719

 -- Marc Deslauriers <email address hidden> Mon, 30 May 2022 13:58:35 -0400




About   -   Send Feedback to @ubuntu_updates