UbuntuUpdates.org

Package "bind9"

Name: bind9

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Transitional package for bind9-utils
  • Transitional package for bind9-dnsutils

Latest version: 1:9.16.15-1ubuntu1.2
Release: impish (21.10)
Level: security
Repository: universe

Links



Other versions of "bind9" in Impish

Repository Area Version
base main 1:9.16.15-1ubuntu1
base universe 1:9.16.15-1ubuntu1
security main 1:9.16.15-1ubuntu1.2
updates universe 1:9.16.15-1ubuntu1.2
updates main 1:9.16.15-1ubuntu1.2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:9.16.15-1ubuntu1.2 2022-03-17 21:07:20 UTC

  bind9 (1:9.16.15-1ubuntu1.2) impish-security; urgency=medium

  * SECURITY UPDATE: cache poisoning via bogus NS records
    - debian/patches/CVE-2021-25220.patch: tighten rules for acceptance of
      records into the cache in lib/dns/resolver.c.
    - CVE-2021-25220
  * SECURITY UPDATE: DoS via specially crafted TCP stream
    - debian/patches/CVE-2022-0396.patch: ensure correct ordering in
      lib/isc/netmgr/netmgr.c.
    - CVE-2022-0396

 -- Marc Deslauriers <email address hidden> Tue, 15 Mar 2022 10:02:18 -0400

Source diff to previous version
CVE-2021-25220 DNS forwarders - cache poisoning vulnerability
CVE-2022-0396 DoS from specifically crafted TCP packets

Version: 1:9.16.15-1ubuntu1.1 2021-10-28 12:06:26 UTC

  bind9 (1:9.16.15-1ubuntu1.1) impish-security; urgency=medium

  * SECURITY UPDATE: resolver performance degradation via lame cache abuse
    - debian/patches/CVE-2021-25219.patch: disable lame cache in
      bin/named/config.c, bin/named/server.c, lib/dns/resolver.c.
    - CVE-2021-25219

 -- Marc Deslauriers <email address hidden> Wed, 27 Oct 2021 06:54:36 -0400

CVE-2021-25219 In BIND 9.3.0 -&gt; 9.11.35, 9.12.0 -&gt; 9.16.21, and versions 9.9.3- ...



About   -   Send Feedback to @ubuntu_updates