UbuntuUpdates.org

Package "apt"




Name: apt

Description:

commandline package manager

Latest version: *DELETED*
Release: hirsute (21.04)
Level: proposed
Repository: main

Links


Download "apt"


Other versions of "apt" in Hirsute

Repository Area Version
base main 2.2.3
base universe 2.2.3
updates main 2.2.4ubuntu0.1
updates universe 2.2.4ubuntu0.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2021-07-16 21:06:27 UTC
No changelog for deleted or moved packages.

Version: 2.2.4ubuntu0.1 2021-06-17 19:06:26 UTC

  apt (2.2.4ubuntu0.1) hirsute; urgency=medium

  * Merge 2.2.4 from Debian unstable
  * Extend the JSON hook fixes with support for version 0.2 (LP: #1926150)
    - json: Add origins fields to version
    - upgrade: Add JSON hook support (AptCli::Hooks::Upgrade)
    - json: Add `package-list` and `statistics` install hooks
    - json: Hook protocol 0.2 (added upgrade,downgrade,reinstall modes)

1926150 [SRU] Backport JSON hooks 0.2

Version: *DELETED* 2021-04-15 12:06:27 UTC
No changelog for deleted or moved packages.

Version: 2.2.3 2021-04-14 15:06:30 UTC

  apt (2.2.3) unstable; urgency=medium

  * tests: Check for and discard expected warning from MaybeAddAuth. For some
    reason, this was only noticed with LTO enabled, but should be a general
    issue.
  * Fix downloads of unsized files that are largest in pipeline (LP: #1921626)
  * Warn on packages without a Size field. Such repositories are broken and
    need to be fixed, as we do not test apt against them, see the bug above
    for more details. Set Acquire::AllowUnsizedPackages to disable the
    warning.

 -- Julian Andres Klode <email address hidden> Tue, 13 Apr 2021 17:53:32 +0200

1921626 size mismatch error if request of unknown size is larger than others



About   -   Send Feedback to @ubuntu_updates