UbuntuUpdates.org

Package "openjdk-lts"

Name: openjdk-lts

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Java runtime based on OpenJDK (demos and examples)
  • Alternative JVM for OpenJDK, using Zero

Latest version: 11.0.9.1+1-0ubuntu1~20.10
Release: groovy (20.10)
Level: updates
Repository: universe

Links



Other versions of "openjdk-lts" in Groovy

Repository Area Version
base universe 11.0.9+10-0ubuntu1
base main 11.0.9+10-0ubuntu1
security main 11.0.9.1+1-0ubuntu1~20.10
security universe 11.0.9.1+1-0ubuntu1~20.10
updates main 11.0.9.1+1-0ubuntu1~20.10

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 11.0.9.1+1-0ubuntu1~20.10 2020-11-12 18:07:06 UTC

  openjdk-lts (11.0.9.1+1-0ubuntu1~20.10) groovy-security; urgency=medium

  * Backport from Hirsute.

Source diff to previous version

Version: 11.0.9+11-0ubuntu1 2020-10-28 02:06:50 UTC

  openjdk-lts (11.0.9+11-0ubuntu1) groovy; urgency=medium

  * OpenJDK 11.0.9+11 build (release).
  * Security fixes:
    - JDK-8233624: Enhance JNI linkage
    - JDK-8236196: Improve string pooling
    - JDK-8236862, CVE-2020-14779: Enhance support of Proxy class
    - JDK-8237990, CVE-2020-14781: Enhanced LDAP contexts
    - JDK-8237995, CVE-2020-14782: Enhance certificate processing
    - JDK-8240124: Better VM Interning
    - JDK-8241114, CVE-2020-14792: Better range handling
    - JDK-8242680, CVE-2020-14796: Improved URI Support
    - JDK-8242685, CVE-2020-14797: Better Path Validation
    - JDK-8242695, CVE-2020-14798: Enhanced buffer support
    - JDK-8243302: Advanced class supports
    - JDK-8244136, CVE-2020-14803: Improved Buffer supports
    - JDK-8244479: Further constrain certificates
    - JDK-8244955: Additional Fix for JDK-8240124
    - JDK-8245407: Enhance zoning of times
    - JDK-8245412: Better class definitions
    - JDK-8245417: Improve certificate chain handling
    - JDK-8248574: Improve jpeg processing
    - JDK-8249927: Specify limits of jdk.serialProxyInterfaceLimit
    - JDK-8253019: Enhanced JPEG decoding

  [ Matthias Klose ]
  * Call strip-nondeterminism before computing jmod hashes (Julian Gilbey).
    Closes: #944738.
  * Build with GCC 10 in current development versions. Closes: #972288.

  [ Tiago Stürmer Daitx ]
  * debian/rules:
    - remove get-orig, gbp import-orig uses uscan and is configured
      to clean the orig package.
    - sanitize v_pkgrel to use in version-opt as it deletes
      any character not in [-.a-zA-Z0-9].
    - prevent deletion of test file on dh_clean.
  * debian/generate-debian-orig.sh, debian/update-hgrev.sh: remove
    outdated files that no longer work.
  * debian/watch: fetch from github and only scan for numeric tags.
  * debian/patches/jdk-8254177-tzdata2020b.patch: update to latest
    tzdata.
  * debian/JB-jre-headless.postinst.in: replace tempfile calls with
    mktemp. Closes: #972245.

 -- Tiago Stürmer Daitx <email address hidden> Thu, 22 Oct 2020 05:15:02 +0000

944738 oneconf-service crashed with AttributeError in _sav...
972288 openjdk-11 FTBFS with gcc-10
972245 openjdk-11-jre-headless: WARNING: tempfile is deprecated; consider using mktemp instead.
CVE-2020-14779 Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Serialization). Supported versions that are affected are Java SE
CVE-2020-14781 Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: JNDI). Supported versions that are affected are Java SE: 7u271,
CVE-2020-14782 Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u
CVE-2020-14792 Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Java SE: 7u27
CVE-2020-14796 Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u
CVE-2020-14797 Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u
CVE-2020-14798 Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u
CVE-2020-14803 Vulnerability in the Java SE product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 11.0.8 and 15. Easil



About   -   Send Feedback to @ubuntu_updates