UbuntuUpdates.org

Package "libpulse-mainloop-glib0"

Name: libpulse-mainloop-glib0

Description:

PulseAudio client libraries (glib support)

Latest version: 1:13.99.2-1ubuntu2.1
Release: groovy (20.10)
Level: security
Repository: main
Head package: pulseaudio
Homepage: http://www.pulseaudio.org

Links


Download "libpulse-mainloop-glib0"


Other versions of "libpulse-mainloop-glib0" in Groovy

Repository Area Version
base main 1:13.99.2-1ubuntu1
updates main 1:13.99.2-1ubuntu2.3
PPA: Ubuntu-desktop ppa 1:13.99.3-1ubuntu1~20.10

Changelog

Version: 1:13.99.2-1ubuntu2.1 2020-11-23 17:08:13 UTC

  pulseaudio (1:13.99.2-1ubuntu2.1) groovy-security; urgency=medium

  * SECURITY UPDATE: don't rely on SCM_CREDENTIALS to detect snap confined
    clients (LP: #1895928)
    - d/p/0409-pa-client-peer-credentials.patch: drop patch
    - d/p/0409-fix-arg-parsing-after-async-hook.patch: remains of old 0409
      patch not related to pa_creds.
    - d/p/0410-pa-client-peer-apparmor-label.patch: new patch, records
      AppArmor label in pa_client struct for native connections using
      aa_getpeercon.
    - d/p/0702-add-snappy-policy-module.patch: use the AppArmor
      label in the pa_client rather than looking it up via the process ID
      from SCM_CREDENTIALS.
    - CVE-2020-16123
   * Don't block classic snaps from module loading/unloading (LP: #1886854)
    - d/p/0702-add-snappy-policy-module.patch: replace
      deny_to_snaps_hook with a version that allows classic snaps.

 -- James Henstridge <email address hidden> Thu, 05 Nov 2020 16:46:59 -0500

1886854 Race in load-module snap policy check in classic confinement
CVE-2020-16123 RESERVED



About   -   Send Feedback to @ubuntu_updates