UbuntuUpdates.org

Package "fwupd"

Name: fwupd

Description:

Firmware update daemon

Latest version: 1.4.7-0~20.10.1
Release: groovy (20.10)
Level: proposed
Repository: main
Homepage: https://github.com/fwupd/fwupd

Links


Download "fwupd"


Other versions of "fwupd" in Groovy

Repository Area Version
base universe 1.4.5-1
base main 1.4.5-1
proposed universe 1.4.7-0~20.10.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.4.7-0~20.10.1 2021-04-08 12:07:22 UTC

  fwupd (1.4.7-0~20.10.1) groovy; urgency=medium

  * new upstream version (1.4.7)
  * Bug fixes:
    - Check returned volumes before accessing them
    - Correct a Thunderbolt assertion if kernel failed FW read
    - Do not dedupe NVMe devices
    - Do not match all HIDRAW\VEN_06CB devices
    - Don't allow device updates while needing activation
    - Fix adding multiple flags to devices
    - Fix critical warning regression with 'fwupdate -a'
    - Fix probe warning for the Logitech Unifying device
    - Fix the quirk key name for the Lenovo HDMI with power
    - Make TPM more optional
    - Make udisks2 errors more apparent
    - Only set the version format for ESRT entries
    - Remove the Hughski public key
    - Restore recognizing gpg and pkcs7 types still
    - Wait a few ms for the Logitech hardware to settle after detach
  * New features
    - Add support for SBAT. (LP: #1921539)
    - Adds support for Synaptics fingerprinter reader (LP:# 1900935)
  * Fixes TPM PCR0 reading failures if all characters are 0.
    (LP: #1909734)
  * Fixes Synaptics RMI probe causing touchscreen failures
    (LP: #1886912)
  * Backport a patch from upstream 1_4_X branch to fix SBAT character.
  * Backport a patch from upstream 1_4_X branch to fix vendor-id requirement
    error on Dell WD19 (LP: #1921544)

 -- Mario Limonciello <email address hidden> Fri, 26 Mar 2021 13:45:02 -0500

1909734 TPM PCR checking will fail if the all characters are 0
1886912 DELL M3800 Touchscreen not working after login (but works if fwupd is removed)
1921544 fwupd 1.2.x, 1.3.x, 1.4.x: vendor-id requirement on LVFS causes failures



About   -   Send Feedback to @ubuntu_updates