UbuntuUpdates.org

Package "librabbitmq"

Name: librabbitmq

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Command-line utilities for interacting with AMQP servers

Latest version: 0.9.0-0.2ubuntu0.19.10.1
Release: eoan (19.10)
Level: updates
Repository: universe

Links



Other versions of "librabbitmq" in Eoan

Repository Area Version
base universe 0.9.0-0.2
base main 0.9.0-0.2
security universe 0.9.0-0.2ubuntu0.19.10.1
security main 0.9.0-0.2ubuntu0.19.10.1
updates main 0.9.0-0.2ubuntu0.19.10.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.9.0-0.2ubuntu0.19.10.1 2019-12-05 16:07:01 UTC

  librabbitmq (0.9.0-0.2ubuntu0.19.10.1) eoan-security; urgency=medium

  * SECURITY UPDATE: Integer overflow
    - debian/patches/CVE-2019-18609.patch: check frame_size is >= INT32_MAX
      in librabbitmq/amqp_connection.c.
    - CVE-2019-18609

 -- <email address hidden> (Leonidas S. Barbosa) Thu, 05 Dec 2019 09:24:57 -0300

CVE-2019-18609 An issue was discovered in amqp_handle_input in amqp_connection.c in rabbitmq-c 0.9.0. There is an integer overflow that leads to heap memory corrupt



About   -   Send Feedback to @ubuntu_updates