UbuntuUpdates.org

Package "mysql-5.7"

Name: mysql-5.7

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • MySQL source
  • MySQL regression tests
  • MySQL 5.7 testsuite

Latest version: 5.7.28-0ubuntu0.19.04.2
Release: disco (19.04)
Level: updates
Repository: universe

Links

Save this URL for the latest version of "mysql-5.7": https://www.ubuntuupdates.org/mysql-5.7



Other versions of "mysql-5.7" in Disco

Repository Area Version
base main 5.7.25-1
base universe 5.7.25-1
security main 5.7.28-0ubuntu0.19.04.2
security universe 5.7.28-0ubuntu0.19.04.2
updates main 5.7.28-0ubuntu0.19.04.2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 5.7.28-0ubuntu0.19.04.2 2019-11-18 15:06:51 UTC

  mysql-5.7 (5.7.28-0ubuntu0.19.04.2) disco-security; urgency=medium

  * SECURITY UPDATE: Update to 5.7.28 to fix security issues
    - CVE-2019-2910, CVE-2019-2911, CVE-2019-2914, CVE-2019-2922,
      CVE-2019-2923, CVE-2019-2924, CVE-2019-2938, CVE-2019-2946,
      CVE-2019-2948, CVE-2019-2960, CVE-2019-2969, CVE-2019-2974,
      CVE-2019-2993
  * Removed patches no longer required:
    - debian/patches/mips64el.patch
  * debian/rules: removed -DWITH_SSL=bundled, option no longer works.
  * debian/control: add libssl-dev to Build-Depends.
  * d/additions/apparmor-profile: add missing AppArmor rules
    (LP: #1658233).

 -- Marc Deslauriers <email address hidden> Fri, 15 Nov 2019 08:23:09 -0500

Source diff to previous version
1658233 missing apparmor rules
CVE-2019-2910 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Security: Encryption). Supported versions that are affected are 5.6.45
CVE-2019-2911 Vulnerability in the MySQL Server product of Oracle MySQL (component: Information Schema). Supported versions that are affected are 5.6.45 and prior,
CVE-2019-2914 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Security: Encryption). Supported versions that are affected are 5.7.27
CVE-2019-2922 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Security: Encryption). Supported versions that are affected are 5.6.45
CVE-2019-2923 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Security: Encryption). Supported versions that are affected are 5.6.45
CVE-2019-2924 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Security: Encryption). Supported versions that are affected are 5.6.45
CVE-2019-2938 Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.27 and prior and 8.0.17 a
CVE-2019-2946 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: PS). Supported versions that are affected are 5.7.27 and prior and 8.0.
CVE-2019-2948 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Optimizer). Supported versions that are affected are 5.7.26 and prior a
CVE-2019-2960 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Replication). Supported versions that are affected are 5.7.27 and prior
CVE-2019-2969 Vulnerability in the MySQL Server product of Oracle MySQL (component: Client programs). Supported versions that are affected are 5.6.44 and prior, 5.
CVE-2019-2974 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Optimizer). Supported versions that are affected are 5.6.45 and prior,
CVE-2019-2993 Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: C API). Supported versions that are affected are 5.7.27 and prior and 8

Version: 5.7.27-0ubuntu0.19.04.1 2019-07-24 17:07:26 UTC

  mysql-5.7 (5.7.27-0ubuntu0.19.04.1) disco-security; urgency=medium

  * SECURITY UPDATE: Update to 5.7.27 to fix security issues
    - CVE-2019-2737, CVE-2019-2738, CVE-2019-2739, CVE-2019-2740,
      CVE-2019-2741, CVE-2019-2757, CVE-2019-2758, CVE-2019-2774,
      CVE-2019-2778, CVE-2019-2791, CVE-2019-2797, CVE-2019-2805,
      CVE-2019-2819

 -- Marc Deslauriers <email address hidden> Mon, 22 Jul 2019 12:43:33 -0400

Source diff to previous version
CVE-2019-2737 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2738 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2739 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2740 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2741 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2757 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2758 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2774 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2778 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2791 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2797 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2805 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...
CVE-2019-2819 Vulnerability in the MySQL Server component of Oracle MySQL (subcompon ...

Version: 5.7.26-0ubuntu0.19.04.1 2019-04-29 15:07:26 UTC

  mysql-5.7 (5.7.26-0ubuntu0.19.04.1) disco-security; urgency=medium

  * SECURITY UPDATE: Update to 5.7.26 to fix security issues
    - CVE-2019-2566, CVE-2019-2581, CVE-2019-2592, CVE-2019-2614,
      CVE-2019-2627, CVE-2019-2628, CVE-2019-2632, CVE-2019-2683
  * Removed patches included in new version:
    - debian/patches/fix-mysqldump-test-dates
  * debian/control: added pkg-config to Build-Depends.

 -- Marc Deslauriers <email address hidden> Thu, 25 Apr 2019 12:41:32 -0400

CVE-2019-2566 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Audit Plug-in). Supported versions that are affected are 5.7.25 an
CVE-2019-2581 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Optimizer). Supported versions that are affected are 5.7.25 and pr
CVE-2019-2592 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: PS). Supported versions that are affected are 5.7.25 and prior and
CVE-2019-2614 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Replication). Supported versions that are affected are 5.6.43 and
CVE-2019-2627 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Security: Privileges). Supported versions that are affected are 5.
CVE-2019-2628 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: InnoDB). Supported versions that are affected are 5.7.25 and prior and 8.0
CVE-2019-2632 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server : Pluggable Auth). Supported versions that are affected are 5.7.25
CVE-2019-2683 Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Options). Supported versions that are affected are 5.6.43 and prio



About   -   Send Feedback to @ubuntu_updates