UbuntuUpdates.org

Package "chromium-browser"

Name: chromium-browser

Description:

Chromium web browser, open-source version of Chrome

Latest version: 76.0.3809.100-0ubuntu0.19.04.1
Release: disco (19.04)
Level: updates
Repository: universe
Homepage: https://chromium.googlesource.com/chromium/src/

Links

Save this URL for the latest version of "chromium-browser": https://www.ubuntuupdates.org/chromium-browser


Download "chromium-browser"


Other versions of "chromium-browser" in Disco

Repository Area Version
base universe 73.0.3683.103-0ubuntu1
security universe 76.0.3809.100-0ubuntu0.19.04.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 76.0.3809.100-0ubuntu0.19.04.1 2019-08-15 18:07:53 UTC

  chromium-browser (76.0.3809.100-0ubuntu0.19.04.1) disco; urgency=medium

  * Upstream release: 76.0.3809.100
    - CVE-2019-5868: Use-after-free in PDFium ExecuteFieldAction.
    - CVE-2019-5867: Out-of-bounds read in V8.

 -- Olivier Tilloy <email address hidden> Sat, 10 Aug 2019 15:55:11 +0200

Source diff to previous version

Version: 76.0.3809.87-0ubuntu0.19.04.1 2019-08-05 13:07:02 UTC

  chromium-browser (76.0.3809.87-0ubuntu0.19.04.1) disco; urgency=medium

  * Upstream release: 76.0.3809.87
    - CVE-2019-5850: Use-after-free in offline page fetcher.
    - CVE-2019-5860: Use-after-free in PDFium.
    - CVE-2019-5853: Memory corruption in regexp length check.
    - CVE-2019-5851: Use-after-poison in offline audio context.
    - CVE-2019-5859: res: URIs can load alternative browsers.
    - CVE-2019-5856: Insufficient checks on filesystem: URI permissions.
    - CVE-2019-5863: Use-after-free in WebUSB on Windows.
    - CVE-2019-5855: Integer overflow in PDFium.
    - CVE-2019-5865: Site isolation bypass from compromised renderer.
    - CVE-2019-5858: Insufficient filtering of Open URL service parameters.
    - CVE-2019-5864: Insufficient port filtering in CORS for extensions.
    - CVE-2019-5862: AppCache not robust to compromised renderers.
    - CVE-2019-5861: Click location incorrectly checked.
    - CVE-2019-5857: Comparison of -0 and null yields crash.
    - CVE-2019-5854: Integer overflow in PDFium text rendering.
    - CVE-2019-5852: Object leak of utility functions.
  * debian/patches/chromium_useragent.patch: refreshed
  * debian/patches/disable-sse2: refreshed
  * debian/patches/fix-extra-arflags.patch: refreshed
  * debian/patches/fix-ffmpeg-ia32-build.patch: removed, no longer needed
  * debian/patches/fix-libstdc++-build-aeed4d1.patch: removed, no longer needed
  * debian/patches/pffft-no-neon.patch: removed, no longer needed
  * debian/patches/set-rpath-on-chromium-executables.patch: refreshed
  * debian/patches/skia-undef-HWCAP_CRC32.patch: refreshed
  * debian/patches/upstream-fix-blink-build-iterators.patch: added

 -- Olivier Tilloy <email address hidden> Tue, 30 Jul 2019 22:41:19 +0200

Source diff to previous version
CVE-2019-5863 RESERVED

Version: 75.0.3770.142-0ubuntu0.19.04.1 2019-07-30 15:07:15 UTC

  chromium-browser (75.0.3770.142-0ubuntu0.19.04.1) disco; urgency=medium

  * Upstream release: 75.0.3770.142

 -- Olivier Tilloy <email address hidden> Tue, 16 Jul 2019 22:11:56 +0200

Source diff to previous version

Version: 75.0.3770.90-0ubuntu0.19.04.1 2019-06-18 22:06:22 UTC

  chromium-browser (75.0.3770.90-0ubuntu0.19.04.1) disco; urgency=medium

  * Upstream release: 75.0.3770.90

 -- Olivier Tilloy <email address hidden> Thu, 13 Jun 2019 22:26:14 +0200

Source diff to previous version

Version: 74.0.3729.169-0ubuntu0.19.04.1 2019-05-29 15:07:09 UTC

  chromium-browser (74.0.3729.169-0ubuntu0.19.04.1) disco; urgency=medium

  * Upstream release: 74.0.3729.169
  * debian/patches/revert-gn-4960.patch: added
  * debian/patches/revert-gn-4980.patch: added
  * debian/tests/data/HTML5test/index.html: mock whichbrowser.net to remove
    external test dependency

 -- Olivier Tilloy <email address hidden> Wed, 22 May 2019 10:15:40 +0200




About   -   Send Feedback to @ubuntu_updates