UbuntuUpdates.org

Package "nss"

Name: nss

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Network Security Service tools

Latest version: 2:3.42-1ubuntu2.5
Release: disco (19.04)
Level: security
Repository: universe

Links

Save this URL for the latest version of "nss": https://www.ubuntuupdates.org/nss



Other versions of "nss" in Disco

Repository Area Version
base main 2:3.42-1ubuntu2
base universe 2:3.42-1ubuntu2
security main 2:3.42-1ubuntu2.5
updates main 2:3.42-1ubuntu2.5
updates universe 2:3.42-1ubuntu2.5

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2:3.42-1ubuntu2.5 2020-01-10 16:25:50 UTC

  nss (2:3.42-1ubuntu2.5) disco-security; urgency=medium

  * SECURITY UPDATE: Possible wrong length for cryptographic primitives input
    - debian/patches/CVE-2019-17006.patch: adds checks for length of crypto
      primitives in nss/lib/freebl/chacha20poly1305.c,
      nss/lib/freebl/ctr.c, nss/lib/freebl/gcm.c,
      nss/lib/freebl/intel-gcm-wrap.c,
      nss/lib/freebl/rsapkcs.c.
    - CVE-2019-17006

 -- <email address hidden> (Leonidas S. Barbosa) Tue, 07 Jan 2020 15:11:00 -0300

Source diff to previous version
CVE-2019-17006 Check length of inputs for cryptographic primitives

Version: 2:3.42-1ubuntu2.4 2019-12-09 14:07:51 UTC

  nss (2:3.42-1ubuntu2.4) disco-security; urgency=medium

  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2019-17007.patch: check got some certs in
      collect_certs r=jcj in nss/lib/pkcs7/certread.c,
      gtests/certdb_gtest/certdb_gtest.gyp,
      gtests/certdb_gtest/decode_certs_unittest.cc,
      gtests/certdb_gtest/manifest.mn.
    - CVE-2019-17007

 -- <email address hidden> (Leonidas S. Barbosa) Thu, 05 Dec 2019 13:46:12 -0300

Source diff to previous version
CVE-2019-17007 nss: Handling of Netscape Certificate Sequences in CERT_DecodeCertPackage() may crash with a NULL deref leading to DoS

Version: 2:3.42-1ubuntu2.3 2019-11-27 16:06:31 UTC

  nss (2:3.42-1ubuntu2.3) disco-security; urgency=medium

  * SECURITY UPDATE: out-of-bounds write in NSC_EncryptUpdate
    - debian/patches/CVE-2019-11745.patch: use maxout not block size in
      nss/lib/softoken/pkcs11c.c.
    - CVE-2019-11745
  * Note: this does _not_ contain the changes from 2:3.42-1ubuntu2.2 in
    disco-proposed.

 -- Marc Deslauriers <email address hidden> Tue, 26 Nov 2019 08:51:03 -0500

Source diff to previous version
CVE-2019-11745 Out-of-bounds write when passing an output buffer smaller than the block size to NSC_EncryptUpdate

Version: 2:3.42-1ubuntu2.1 2019-07-16 13:07:30 UTC

  nss (2:3.42-1ubuntu2.1) disco-security; urgency=medium

  * SECURITY UPDATE: OOB read when importing a curve25519 private key
    - debian/patches/CVE-2019-11719.patch: don't unnecessarily strip
      leading 0's from key material during PKCS11 import in
      nss/lib/freebl/ecl/ecp_25519.c, nss/lib/pk11wrap/pk11akey.c,
      nss/lib/pk11wrap/pk11cert.c, nss/lib/pk11wrap/pk11pk12.c,
      nss/lib/softoken/legacydb/lgattr.c, nss/lib/softoken/pkcs11c.c.
    - CVE-2019-11719
  * SECURITY UPDATE: incorrect use of PKCS#1 v1.5 signatures with TLSv1.3
    - debian/patches/CVE-2019-11727.patch: prohibit use of
      RSASSA-PKCS1-v1_5 algorithms in TLS 1.3 in
      nss/gtests/ssl_gtest/ssl_auth_unittest.cc,
      nss/gtests/ssl_gtest/ssl_ciphersuite_unittest.cc,
      nss/gtests/ssl_gtest/ssl_extension_unittest.cc,
      nss/lib/ssl/ssl3con.c.
    - CVE-2019-11727
  * SECURITY UPDATE: segfault via empty or malformed p256-ECDH public keys
    - debian/patches/CVE-2019-11729-1.patch: more thorough input checking
      in nss/lib/cryptohi/seckey.c, nss/lib/freebl/dh.c,
      nss/lib/freebl/ec.c, nss/lib/util/quickder.c.
    - debian/patches/CVE-2019-11729-2.patch: ignore spki decode failures on
      negative tests in nss/gtests/pk11_gtest/pk11_curve25519_unittest.cc.
    - CVE-2019-11729

 -- Marc Deslauriers <email address hidden> Fri, 12 Jul 2019 07:48:06 -0400




About   -   Send Feedback to @ubuntu_updates