UbuntuUpdates.org

Package "ubuntu-release-upgrader"

Name: ubuntu-release-upgrader

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • manage release upgrades
  • manage release upgrades
  • manage release upgrades

Latest version: 1:19.04.16.7
Release: disco (19.04)
Level: updates
Repository: main

Links

Save this URL for the latest version of "ubuntu-release-upgrader": https://www.ubuntuupdates.org/ubuntu-release-upgrader



Other versions of "ubuntu-release-upgrader" in Disco

Repository Area Version
base universe 1:19.04.16
base main 1:19.04.16
updates universe 1:19.04.16.7

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:19.04.16.7 2019-10-09 21:07:00 UTC

  ubuntu-release-upgrader (1:19.04.16.7) disco; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py, DistUpgrade/DistUpgradeCache.py:
    Modify DistUpgradeQuirks to calculate extra space needed for snaps that
    need to be installed during upgrade (replacing old debs) and add that to
    estimates done in checkFreeSpace(). (LP: #1783597)
  * DistUpgrade/DistUpgradeCache.py: Make sure checkFreeSpace() still works for
    update-manager with its own implementation of MyCache.
  * DistUpgrade/DistUpgradeQuirks.py: Make sure snaps like core18 are not
    refreshed/installed from the stable/ubuntu-VERSION branch but instead use
    stable on upgrades. (LP: #1841225)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Mon, 09 Sep 2019 15:41:12 +0200

Source diff to previous version
1783597 The disk-space-needed estimate doesn't account for the snaps
1841225 deb to snap transition uses an ubuntu release channel for the core18 snap

Version: 1:19.04.16.6 2019-07-01 09:06:26 UTC

  ubuntu-release-upgrader (1:19.04.16.6) disco; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: only try to install snaps if snapstore
    is reachable. (LP: #1831933)

 -- Dan Streetman <email address hidden> Wed, 19 Jun 2019 12:49:56 -0400

Source diff to previous version
1831933 do-release-upgrade tries to install snaps even if it knows it can't reach the snapstore

Version: 1:19.04.16.5 2019-05-22 17:06:50 UTC

  ubuntu-release-upgrader (1:19.04.16.5) disco; urgency=medium

  [ Gunnar Hjalmarsson ]
  * DistUpgrade/window_main.ui: Really update for 19.04 (LP: #1825733).

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeViewNonInteractive.py: when responding to a
    conffile prompt with "n" use bytes not a string. (LP: #1796193)

 -- Brian Murray <email address hidden> Fri, 10 May 2019 15:19:00 -0700

Source diff to previous version
1825733 ubuntu-release-upgrader-core shows upgrading from 18.10 to 18.10
1796193 DistUpgradeViewNonInteractive crashes / requires interaction

Version: 1:19.04.16.4 2019-05-13 21:06:37 UTC

  ubuntu-release-upgrader (1:19.04.16.4) disco; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: modify function which updates snaps so
    that it determines the release from which a system is being upgraded.
    Additionally, update the channel for the snap to reflect the release to
    which we are upgrading. (LP: #1827951)
  * data/DistUpgrade.cfg.bionic, data/DistUpgrade.cfg:
    - update KernelRemoval sections to kernel packages that appear in
      Ubuntu 18.04 and Ubuntu 18.10. (LP: #1828072)

1827951 snaps not refreshed when upgrading from bionic or cosmic to disco
1828072 KernelRemoval section is out of date

Version: *DELETED* 2019-05-04 03:10:20 UTC
No changelog for deleted or moved packages.



About   -   Send Feedback to @ubuntu_updates